Ask Your Question
0

Writer crashes

asked 2017-06-24 16:06:31 +0200

theshadowphoton gravatar image

For some reason Libreoffice-still 5.2.7-1 Writer crashes when I try to open any of my documents (.odt, .doc, any file type). Calc opens documents as it should... and I haven't tested Impress. When I try to start Writter via terminal, after the crash there is no error output.

This started happening today. I'm on 32bit Arch linux with xfce desktop - forum topic here https://bbs.archlinux.org/viewtopic.p... and I've found that this issue is present on ubuntu as well https://askubuntu.com/questions/92785...

Does anyone know how to solve this?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2017-06-25 11:12:15 +0200

theshadowphoton gravatar image

I've managed to solve this issue by turning off Java in Libreoffice>

First, start Libreoffice, click on Tools, click on options and under Libreoffice section click on Advanced. Deselect "Use a Java runtime environment" and problem solved.

I don't think this a good solution, but considering I don't use Java in Libreoffice it's good enough for me.

edit flag offensive delete link more

Comments

Is there a method to turn off Java from outside the GUI? I can't start any LibreOffice application, not even the main application. All of them crashes at start. I'm in Ubuntu 14.04

polofi gravatar imagepolofi ( 2017-06-26 11:03:33 +0200 )edit

Thank you for this solution. I am in Debian 9.3, just installed, and Writer crashed prior to opening. Your instructions solved the problem.

EBR gravatar imageEBR ( 2018-03-03 23:20:47 +0200 )edit
0

answered 2017-06-24 17:05:29 +0200

harritapio gravatar image

updated 2017-06-24 17:08:36 +0200

I had the same problem with debian 9 (32 bit) and LibreOffice I could not open any .odt or .doc files. Because I could not find any solution for the problem I finally installed debian 9 as 64bit version and the problem is solved.

If your pc is compatible with 64bit, you may bypass the problem on this way!

edit flag offensive delete link more

Comments

Thank you for your answer. I've managed to find the solution. I'm not sure how kernel update triggered this, but it did.

Nevertheless, I've turned off Java and Writer started working again.

theshadowphoton gravatar imagetheshadowphoton ( 2017-06-25 11:09:12 +0200 )edit
0

answered 2017-07-22 00:29:27 +0200

my father's pc with slackwre-current (32-bit) and kernel 4.12.2 had the same problem. Examining what happened I noticed there's a ""soffice.bin" received signal SIGSEGV, Segmentation fault. 0xa1f35f3a in _expand_stack_to(unsigned char*) () from /usr/lib/java/jre/lib/i386/server/libjvm.so" I had that problem executing LO as user, while everything worked perfectly if I logged as root, and with kernels released since Jun 24 because that kernels had a mmap problem fixed. In the beginning I disabled the JAVA from Optons --> Advanced and LO correctly opened odt documents, nomore crashes. The following day I found a solution working for slackware, without the need to disable JAVA in LO, please check if it works for other distros. I've simply passed at boot time the following option to the kernel: stack_guard_gap=1 With this kernel option LO was working perfectly again.

Nicola

PS: Question: Exactly which functionalities I loose disabling JAVA from Optons --> Advanced ??

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-06-24 16:06:31 +0200

Seen: 3,497 times

Last updated: Jul 22 '17