Ask Your Question
3

Paste unformatted text default option [closed]

asked 2012-03-09 03:28:20 +0100

undoIT gravatar image

updated 2013-02-24 16:14:38 +0100

manj_k gravatar image

Is there any way to set Paste Special (Unformatted text) as the default option when using Ctrl Shift V to paste in Calc, Writer etc? I have read that it is possible to create a macro and then assign a keyboard shortcut to it. I'm just wondering if there is a configuration option to toggle pasting formatted text to unformatted text as the default so that a paste special prompt isn't displayed every time I paste some formatted text.

Alternatively, is there a way to set the import options to a default so that there isn't a prompt for import options after pressing Ctrl V to paste?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-18 22:39:09.833715

Comments

None of these options work or are clearly explained. The actual solution is to select the cell you want to paste into, and then select the forumla bar at the top and CTRL + V to paste into the formula bar and NOT the cell.

codeliger gravatar imagecodeliger ( 2015-11-25 00:13:25 +0100 )edit

6 Answers

Sort by » oldest newest most voted
7

answered 2012-03-18 17:22:43 +0100

manj_k gravatar image

updated 2012-03-18 17:27:21 +0100

My favorite shortcut key for 'Paste unformatted text' is 'Ctrl+U', assigned to that macro:

sub paste_unformatted
rem ----------------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem ----------------------------------------------------------------------
dim args1(0) as new com.sun.star.beans.PropertyValue
args1(0).Name = "SelectedFormat"
args1(0).Value = 1

dispatcher.executeDispatch(document, ".uno:ClipboardFormatItems", "", 0, args1())

end sub

You may create this macro as follows:

(1) Record macro

Ctrl+Shift+V > U > Enter

Stop recording

(2) [New window: LibreOffice Basic Macros]

Type 'Macro name' (e.g.): 'paste_unformatted' > Save

(3) Tools > Customize > Keyboard > Functions > Category > LibreOffice Macros > user > Standard > Module1

Function > 'paste_unformatted'

Shortcut keys > Ctrl+U > Modify > OK

Customize 'Ctrl+U'

edit flag offensive delete link more
4

answered 2012-04-25 07:45:01 +0100

Robert Reese gravatar image

Actually, it is quite easy. Just follow these steps (on the PC version 3.5, at least):

  1. Click on Tools
  2. Click on Customize...
  3. Click on the Keyboard tab at the top
  4. To the RIGHT of the Shortcut Keys box, click on LibreOffice
  5. Below the Shortcut Keys box, find the Functions box, then find and click on Edit
  6. In the next box, the Function box, find and click on Paste Unformatted Text
  7. In the Shortcut Keys box above, find and click once on Ctrl+V
  8. On the RIGHT, click the button titled Modify
  9. Optional: Click the Save... button and save your keyboard configuration so you can import in into another computer or if you reinstall LibreOffice
  10. Click the OK button at the bottom to finish.

That's it! :)

HTH, Robert~

edit flag offensive delete link more

Comments

Thanks Robert! Worked like a charm. I'm using Ubuntu 12.04 LTS and LibreOffice 3.5.7.2.

CoalaWeb gravatar imageCoalaWeb ( 2013-08-23 10:05:55 +0100 )edit

Hi,

Just Signed In to say thank you Robert.

I am regularly copying and pasting text from SQL Server Management Studio Query Editor to Writer and was tired of waiting for the text color format to be retrieved when forgetting to type Shift with Ctrl+V.

This trick will save time and nerves.

a+,=) -=Finiderire=-

Configuration : LibreOffice v4.1.2.3 Portable Windows 7 Service Pack 1 Professionnal

Finiderire gravatar imageFiniderire ( 2013-11-13 15:14:51 +0100 )edit

Thanks

Estersios gravatar imageEstersios ( 2014-05-17 12:58:02 +0100 )edit

In LibreOffice 4.3.0.4, the Paste Unformatted Text option is not present.

Dave Jarvis gravatar imageDave Jarvis ( 2014-09-18 02:02:23 +0100 )edit

This option prevents pasting pictures.

Genom gravatar imageGenom ( 2015-10-17 22:44:51 +0100 )edit

@Genom: yes but once Ctrl+V is "paste unformatted text", you can still use Ctrl+Shift+V (paste special) for pictures, or assign a different shortcut to the standard "paste".

dfaure gravatar imagedfaure ( 2017-03-10 13:30:35 +0100 )edit
2

answered 2012-09-14 07:07:06 +0100

updated 2012-09-14 07:09:04 +0100

"In Writer text documents, you can press Ctrl+Alt+Shift+V to paste the contents of the clipboard as unformatted text. " http://help.libreoffice.org/Common/Pasting_Contents_in_Special_Formats

Doesn't exactly deal with defaults, but perhaps useful in the meanwhile!

edit flag offensive delete link more

Comments

Actually, this is a "default" behaviour, because it shortcuts pressing CTRL+SHIFT+V and then selecting "Unformatted Text" to only one step.

desci gravatar imagedesci ( 2015-09-20 05:50:52 +0100 )edit
0

answered 2012-11-02 06:24:53 +0100

usha gravatar image

i did same paste special, but it doesn't work. the formula is still on active. ideally after paste special formula should not reflect.

edit flag offensive delete link more
0

answered 2012-03-09 17:15:06 +0100

jofilho gravatar image

Unfortunately, these options are not so configurable and you'll need a macro to do what you wanting.

edit flag offensive delete link more
0

answered 2012-03-09 18:20:24 +0100

I don't know how to make a makro, but it should do the follwing (German UI...): Press: ALT + B + H Press: ENTER Press: ENTER

edit flag offensive delete link more

Question Tools

4 followers

Stats

Asked: 2012-03-09 03:28:20 +0100

Seen: 39,011 times

Last updated: Nov 02 '12