Ask Your Question
1

calc slow loading when connected to network

asked 2013-01-24 17:32:39 +0200

PhilC gravatar image

updated 2015-08-27 10:51:03 +0200

Alex Kemp gravatar image

I am using LibreOffice 3.5.4.2 under Ubuntu 12.04.1.

I have a large spreadsheet in ODS format and it takes about 15 seconds to load into Calc. However, if I disable my PC's network connection it takes less than one second.

If I cause my network connection to have a high packet loss (50%, say) it takes many minutes to load!

It looks as if Calc is spending time during the load process accessing something on the Internet and wasting time to do that.

How can I tell Calc not to bother with the Internet like this?

Any advice will be most welcome.

edit retag flag offensive close merge delete

Comments

1

Are you able to use some kind of network monitoring software to see if there is a spike in network traffic and where it is to (and from)?

Joe1234 gravatar imageJoe1234 ( 2013-01-26 09:11:53 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2013-02-25 06:02:16 +0200

qubit gravatar image

Hi @PhilC,

This is very bizarre result! I'd be interested to hear what you find from doing some kind of networking monitoring (per what @Joe1234 suggested).

As for how to fix this, the simplest thing to do is to grab the latest release, cross your fingers, click your heels together, and test again. If that doesn't work (hey, sometimes you get lucky...), please file a bug and provide a list of steps that can reproduce it. If you can attach the particular file that's causing so much slowdown to that bug report, it could help the QA team track down your issue even faster!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more
0

answered 2013-01-26 07:58:53 +0200

ROSt52 gravatar image

I am not sure, but I guess that the internet connection just takes resources from you CPU thus loading is done with a smaller portion of you CPU thus slowing down. Thus I feel it is a question of your PC and/or Unbutu.

edit flag offensive delete link more
0

answered 2015-05-17 16:51:47 +0200

KeithSand gravatar image

I have the same problem. Blank document takes 2s with network disconnected, 40s with network connected and 420s when I turn on the PC with the printer attached. So the work-around for me is to set the default printer to be non-hardware (XPS document writer).

Posted as "bug# 91346".

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-01-24 17:32:39 +0200

Seen: 647 times

Last updated: May 17 '15