Ask Your Question
0

how change default margins in template

asked 2017-06-30 06:19:08 +0100

catbill gravatar image

I have had no problems changing character or paragraph settings in the default template. However, I cannot figure out how to save margin settings in the default template. There are two specific issues I would like help with:

Changing the template so that a new document automatically opens with the margins I want.

Changing the template so that the default settings for Normal and Narrow margins are what I want.

I have done the following: 1. opened the template manager, clicked on the default template and selected edit.
2. changed the normal margins in the Properties deck 3. changed the margins in the page style in the Styles and Formatting deck. 4. saved the default template by agreeing to replace the previous version

No matter what I do, I cannot see how to get these changes saved in the default template.

What could be causing my earnest desire to be thwarted like this?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-01-13 16:45:00 +0100

Mike Kaganski gravatar image

The issue here must be the naming of the "Default" template. Despite its name, it is not used to create new documents by default :) You must explicitly set it to be default by right-clicking on it in template manager, and choosing relevant option.

To be specific: unless some template is set to be default, LibreOffice doesn't use any templates. It creates new documents from its internal defaults, taking user locale into consideration.

edit flag offensive delete link more
0

answered 2018-01-13 16:23:01 +0100

ewald gravatar image

I am on Version: 5.1.6.2 Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2 and just did the following: open template manager, select default (on the documents tab), select edit, the default.ott opens. So far the two of us should have done the same. I am not exactly sure what you mean by point 2 in your description. What I do at this point I edit the default page style, accessible either through Styles>Styles and Formatting or through hitting F11. In the Styles Window select Page Styles right click Default and select Modify. On the Page pane edit the margins and close the result. In my version I am not asked if I want to replace the original default. When I open a new writer document after this the changes I have made are reflected. I know that this doesn't help you unless the problem is hidden in point 2 of your description.

It could also be that you are on another LO version than I am. Therefore: another way to do this is to open a document change the default page style according to your needs and save the document as (File>Save As) default.ott in the /home/<user>/.config/libreoffice/<versionnumber>/user/template. The path to the location of the templates varies depending what OS you are on. I am on Linux Mint 18.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-06-30 06:19:08 +0100

Seen: 128 times

Last updated: Jan 13