Ask Your Question
0

How to insert figure caption numbering according to headings numbering ?

asked 2017-07-04 17:49:43 +0200

Joeynn gravatar image

I want to assign the figure caption to heading numbering. - Now I have 4 photos per example - Tools > Outline Numbering > Level 2 (paragraph style heading 2) == Results: 1.1 1.2 1.3 1.4 ... etc - Tools > Outline Numbering > Level 3 (paragraph style heading 3) == Results: 2.1 2.2 2.3 2.4 ... etc - when I insert caption for figures the results is always Figure 1 then Figure 2 then Figure 3 even if i modified numbering captions by chapter levels

  • How can I make photo 1 caption (Figure 1.0) and photo 2 (Figure 1.1) photo 3 (Figure 2.0) photo 4 (Figure 2.1) ?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2017-07-05 11:24:45 +0200

ajlittoz gravatar image

updated 2017-07-09 07:55:51 +0200

I suppose you inserted your figure first by creating a frame (Insert>Frame>Frame...) and then added a caption with menu Insert>Caption ... after clicking inside the frame.

The dialog which opens allows you to set many properties of the caption.

If the preview does not show something like Figure 1.1, click on the Options button.

The first item in this second dialog is Numbering figures per chapter (or equivalent in your locale). The drop-down menu allows control on the number of levels displayed (from none up to 10). For chapter numbers only, choose Level: 1.

Other options are rather for fancy text decoration and layout but you can experiment to your liking.

Click OK twice and you're done.

EDIT (to answer @Joeynn's questions in comments)

Chapter numbering in captions will work only if outline numbering is enabled. You enable it with Tools>Chapter numbering... and choosing a numbering style for the adequate Heading x paragraph style.

If there is no numbering, chapter number is "void" and this "void" is transferred into the caption which gives a correctly numbered caption "void"-then-sequential-figure-number.

With chapter numbering enabled, you get chpter-number/separator-/sequential-number. If your chapter one contains no figure, the first figure in chapter two is captioned 2.1 as expected.

END OF EDIT

COMMENTS ON YOUR SAMPLE FILE

The most important comment is you are not using LO as it should be: there is a mixture of old-fashioned typewriter usage with modern document processing features. It looks like you are discovering /learning LO while you have a deadline with a professional task.

LO is based on styles, the most important of which are paragraph styles. Their parameters (attributes) allow you to set all visual characteristics of the geometric area occupied by the paragraph: spacing above and under (must never be achieved with "carriage return" strokes), alignment with page break (again, not to be done with carriage returns because a simple text update will ruin your manual sync), first line indent (without the need for Tab character).

Let's start with your text. It is styled Default Style; it should be Text Body. Default Style is the ancestor of all styles and should be used only to set globally shared attributes, usually only the font.

Open the style navigator with F11. Right click Text Body and chose Modify.... Go to Indents & Spacing tab. Set First line indent to 1 cm, Spacing above and below to 0.3 cm (you may prefer some non symmetric values, experiment) and maybe Line spacing to Single instead of your 120%. Go to Alignment tab and set Options to Justified (it is usually better to justify paragraphs extending on the full width of the page). Click OK.

In your "main text" paragraphs, you can now suppress the initial Tabs and manual spacing above/under. With the cursor inside the paragraph, double-click on Text Body and your paragraph is restyled. All modifications made on the style will be ... (more)

edit flag offensive delete link more

Comments

I can not figure out where is chapter numbering located, here are my settings: link text can you help me with a video please ? outline numbering level 3 begins with 2.1, when i choose level 3 in numbering captions by chapter, it gives me 2.0 figure 1 not figure 2.0

Joeynn gravatar imageJoeynn ( 2017-07-05 20:39:03 +0200 )edit

1/ In the latest LO release, menu Tools>Ouyline Numbering changed to Outline>Chapter Numbering. You are on the correct menu to enable chapter (=outline) numbering.

ajlittoz gravatar imageajlittoz ( 2017-07-06 08:18:00 +0200 )edit

2/ Your settings are very strange: Heading 1 (usually chapter title style) is not numbered, hence no chapter number. I can't tell for Heading 2 (sub-chapter) and hope it has Show sublevels set at 2 without anything in Separator Before. Your Heading 3 (section in subchapter) is definitely buggy: sublevels set at 1 means you display no chapter nor subchapter (note this is a valid choice), but you force a constant 2. before the number with Separator before.

ajlittoz gravatar imageajlittoz ( 2017-07-06 08:18:19 +0200 )edit

3/ Try to upload your file because I can't imagine what you've done with such a terse description.

ajlittoz gravatar imageajlittoz ( 2017-07-06 08:25:10 +0200 )edit

Thank you for your help, Here is my file: link text There are 4 Images in the document. Image 1 is in chapter 1 (its caption should be figure 1.0) Image 2 - 3 - 4 are in chapter 2 and there caption should be: Image 2 [figure 2.0] Image 3 [figure 2.1] Image 4 [figure 2.2]

Joeynn gravatar imageJoeynn ( 2017-07-06 17:35:49 +0200 )edit
0

answered 2017-07-05 13:35:42 +0200

Joeynn gravatar image

When I choose Insert>Caption (Category: Figure)>Options>Numbering Captions by Chapter>Level 1 Here is the result: image description and when I choose Insert>Caption (Category: Figure)>Options>Numbering Captions by Chapter>Level 2 Here is the result: image description Is there something wrong ? the preview in the insert caption menu isn't the same caption format in level 2

edit flag offensive delete link more

Comments

Preview is updated after OK on Caption Options because options are validated only after OK. In your snapshots, Preview is consistent with pre-existing options, i.e. "none" when you set "1", then "1" (as set by your first attempt) when you choose "2". The options do not update existing captions.

To get your expected results, delete existing captions and insert new ones.

ajlittoz gravatar imageajlittoz ( 2017-07-05 14:00:19 +0200 )edit

I haven't overwrite a caption over an existing ones. I inserted new ones with these configurations, my snapshots was only to show you the settings I have used. These are my steps: 1- Insert > Image 2- Insert> Caption 3- Options > Numbering Captions by Chapter > Level 2 4- Category: Figure 5- Preview: Figure 1.1: Results 6- What I get in the caption is Figure 1: Results not Figure 1.1: Results

Joeynn gravatar imageJoeynn ( 2017-07-05 16:06:11 +0200 )edit

I have a question also, how can the numbering caption begins with 2? Example: Figure 2.1 Figure 2.2. I can't figure it out

Joeynn gravatar imageJoeynn ( 2017-07-05 16:12:21 +0200 )edit

See edit of my answer

ajlittoz gravatar imageajlittoz ( 2017-07-05 18:07:41 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-07-04 17:49:43 +0200

Seen: 3,225 times

Last updated: Jul 09 '17