Ask Your Question
0

CALC: default date format

asked 2017-07-04 22:57:23 +0200

lovecraft22 gravatar image

Dear all, my computer (Mac) language is English but I would like LO to show dates in Italian Format. Currently dates are shown as MM/DD/YY by default and I would like them to be DD/MM/YY instead. How can I do this?

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-07-05 00:35:53 +0200

m.a.riosv gravatar image

Please test changing the regional setting on Menu/Tools/Options/Language settings/Locale - Locale setting to Italian

edit flag offensive delete link more
0

answered 2017-07-05 01:02:11 +0200

Lupp gravatar image

updated 2017-07-05 01:05:01 +0200

DD/MM/YY is not specific for Italy. It is used in many locales. Under Italian locales it is coded GG/MM/AA.
Your locale seems to be 'English (USA)'. It is (next to) the only locale using MM/DD/YY by default. With 'English (UK)' the default date format would be as you want.

You can set the language for the respective cells to any locale you want. You may do so for the LibO application. You may also set the 'Numbers' format for the respective cells directly to DD/MM/YY. Or you can define a cell style set to this date format.

You should not choose the locale 'Italian (Italy)' if you don't live/work in/for Italy because this is the only locale worldwide using a stubborn time format that causes problems in specific cases. It is the one locale not recognizing e.g. 11:30:45 if entered as a time. This in contradiction with the applicable standard ISO 8601.
You would also get the comma as the decimal separator with Italian locales. This is not bad, but do you want this?

Also: Consider to abandon 2-digit-year formats. They are ambiguos. A few people born in 1917 e.g. are still living. There are more cases where 2-d-y cause problems.

edit flag offensive delete link more

Comments

Thanks! Setting the locale to English UK solved my issue.

lovecraft22 gravatar imagelovecraft22 ( 2017-07-05 08:04:42 +0200 )edit

"Consider to abandon 2-digit-year formats." - but how do you set a 4-digit-year as the default?

MrP gravatar imageMrP ( 2018-10-10 23:54:59 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-07-04 22:57:23 +0200

Seen: 2,179 times

Last updated: Jul 05 '17