Ask Your Question

How can I set the default styles when opening a csv file? [closed]

asked 2017-07-05 09:12:55 +0100

quazgar gravatar image

When opening a CSV file, LibreOffice Calc seems to use its internal defaults for styles, no matter if I set a default document template or not. That means it will use Letter sized pages, in portrait orientation, whereas I need A4, in landscape.

Is there a way to tell localc which page format to use for importing non-ods files?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-10-09 11:53:29.060452

1 Answer

Sort by » oldest newest most voted

answered 2017-07-05 16:51:59 +0100

Lupp gravatar image

Just tested. I would judge this a bug. It may be connected with the way a specific OS handles "associations".

However, if you 'Insert from File' a new sheet selecting a csv as the source, the newly created sheet will use the default styles you defined in your 'Standard' template for Calc. At least it worked for me this way in LibO V5.3.4 Calc.

edit flag offensive delete link more


Thanks for testing this behavior and the tip. I think I will use the "insert" way for cases when I know I will print the data, but will file a bug anyway, because I often open csv files quickly either from a file browser or from the command line with xdg-open. Edit: There was already a bug filed a few years ago.

quazgar gravatar imagequazgar ( 2017-07-06 08:56:26 +0100 )edit

@quazgar: If you actually file the bug, please place a link to it either in a next comment here or by editing your question. If I got it right the default link-text here is like tdf#dd where dd is the complete number of the bug (currently 6 digits).

Lupp gravatar imageLupp ( 2017-07-06 10:40:08 +0100 )edit

Hmm, that format does not seem to work: tdf#86336 (The bug is old, it has only 5 digits.) But that's the number, and the link can be found in my first comment.

quazgar gravatar imagequazgar ( 2017-07-06 19:35:20 +0100 )edit

The format doesn't create the link (as a similar one does in the It is used nonetheless but linked manually.
You wanted to link to bug tdf#86336.

Lupp gravatar imageLupp ( 2017-07-06 20:04:45 +0100 )edit

Question Tools

1 follower


Asked: 2017-07-05 09:12:55 +0100

Seen: 634 times

Last updated: Jul 05 '17