Ask Your Question
1

text form field and reference to bookmark

asked 2013-01-30 18:06:26 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi everybody,

I have the following problem:

I developed through the text form field option an automatic compilation of several pages in Microsoft Word. Through the field "Ref" I linked the information I need to reply in other several places in the document, saving a lot of data input. When I try to open the .doc (or .rtf) with Libre Office, there aren't the links anymore: I pratically lost all my job. Any suggestion?

Thanks in advance! Marco

edit retag flag offensive close merge delete

Comments

Hi @Marco, another crystal ball lost. :). Please can you report your Operating System, LibreOffice version, and document type and version of MS Word used to save?. To do easier that someone can help.

m.a.riosv gravatar imagem.a.riosv ( 2013-01-30 22:35:11 +0200 )edit

Hi @mariosv, thanks, for sure. I use Windows XP and Libre Office 4.0. The file I created is a .doc, developed on MS 2007. When I try to bring it to Libre Office references disappear :( I tried to use a .rft file, with no success or rather with worse results

Iceferra gravatar imageIceferra ( 2013-01-31 10:07:23 +0200 )edit

Thanks @mariosv, for sure. I have windows XP and Libre Office 4.0. I developed the .doc file on MW 2007 and the problem arrive when I try to open it on Libre Office. Using a .rtf file does not risolve the issue.

Iceferra gravatar imageIceferra ( 2013-01-31 10:36:54 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-01-22 01:28:37 +0200

titantux gravatar image

Hi, it happens to me even on LO 4.4.0.X, but noticed than on Office it does not matter field & bookmark name as capital or small letters, so in order to fields/bookmarks work in a good way on LO when document was made on Office is to change bookmarks as CAPITAL as name is on the field.

Here are some handy keyboard shortcuts to use when working with fields:

Ctrl +F2 Open the Fields dialog box.

Ctrl+F8 Turn field shadings on or off.

Ctrl+F9 Show or hide field names.

F9 Update fields

edit flag offensive delete link more
0

answered 2013-02-24 21:49:08 +0200

qubit gravatar image

updated 2013-03-04 22:41:24 +0200

Hi @Iceferra,

The RTF file format has a very limited feature set, I believe. RTF may not includ the capability to store various (any?) form elements. I'd suggest you save this kind of file as .odt, and then save-out versions in other formats (.doc, .rtf, etc...) only when you need to distribute that file with people who can't consume ODF file formats.

It's possible (although I think unlikely) that RTF can have support for this kind of form element, but LO doesn't support it yet. It's very possible that .DOC has this kind of support, but that LO doesn't support it yet. Please feel free to file an enhancement bug. Don't forget to mark your bug as an 'enhancement'. The QA team will be happy to help you triage your feature request in the bugtracker.

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-01-30 18:06:26 +0200

Seen: 1,145 times

Last updated: Jan 22 '15