Ask Your Question
0

How do I get cmd-V paste to work in Base OSX?

asked 2017-07-14 15:37:21 +0200

patpend gravatar image

The command-V keyboard shortcut for paste doesn't work on Base forms running on OSX (specifically MacOS Sierra).

Pasting does work if you use the Edit>Paste menu.

Interestingly, the cut, copy and undo keyboard shortcuts (cmd-X, cmd-C, cmd-V) work as expected in Base. And all the shortcuts work in Write, Calc, etc.

Please help me understand what could be the problem and how I can correct it.

thank you, Russell

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-07-14 19:49:14 +0200

librebel gravatar image

Hello @patpend,

please check if the Cmd+V shortcut key is assigned to any command in LO Base. ( LO Base.should not have any command assigned to the Cmd+V shortcut key, else it overrules the Paste-command assigned to the Cmd+V shortcut key in LibreOffice ):

  1. Select "Tools : Customize...",
  2. Select the tab "Keyboard",
  3. Make sure that the option button "Base" is selected, not the option button "LibreOffice",
  4. In the listbox "Shortcut Keys", scroll down to the row that starts with "Cmd+V",
  5. If there is any other text in this row to the right of "Cmd+V", then there is a command assigned to this key.
edit flag offensive delete link more

Comments

Thanks for the response. There is no other text in this row to the right of "Cmd+V". I checked in the main window (option button Base) and in my form window which has a main form and linked subform (option button Base: Database Form). Each is blank. Is there any other form or context where cmd-V could be remapped? Thanks, Russell

patpend gravatar imagepatpend ( 2017-07-19 14:22:58 +0200 )edit

then it must be something else ...

i can think one more thing to try, is to assign the Paste-command to the Cmd+V shortcut key in Base.

Same steps as above, with these inserted steps:

1.
2.
3.
  3a. In the listbox "Category", select the item "Edit",
  3b. In the listbox "Functions", select the item "Paste",
4. In the listbox "Shortcut Keys", scroll down to the row that starts with "Cmd+V" and select it,
  4a. Click the button "Modify".
librebel gravatar imagelibrebel ( 2017-07-19 15:10:17 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-07-14 15:37:21 +0200

Seen: 43 times

Last updated: Jul 14 '17