Navigation mode in Calc is tied to the language change hotkeys in Kubuntu

asked 2017-07-21 12:23:02 +0100

quaz gravatar image

updated 2017-07-25 15:58:48 +0100

erAck gravatar image

There is an odd bug in LibreOffice Calc: when I change the language, the navigation mode within the table also changes.

By saying 'navigation mode' I mean the Calc's response on pushing arrow keys. The default behavior after pushing the arrow key is selection of the adjusted cell in the respective direction (up, down, right or left). However, after I change the language in Kubuntu, arrow keys in Calc start behaving as scrollbar controllers.

First I thought that such behaviour of Calc is bind to specific key combination alt+shift. However, I tried to change the combinations for changing language and the problem persisted. Since I use several languages in my spreadsheet it is really annoying.

Is there a workaround to the problem? I suppose this bug is so obvious, that it must have been reported earlier

LibreOffice version is 5.3.1.2 Kubuntu version is 17.04

edit retag flag offensive close merge delete