Ask Your Question
0

When I type X1 in calc it turns into 01.10.2001 (Slovak or Polish locale)

asked 2017-07-31 08:55:42 +0200

cpy gravatar image

updated 2017-07-31 13:45:25 +0200

Lupp gravatar image

When I type X1 in calc it turns into 01.10.2001 how to disable auto format? How do I disable this bug? Any work around? Will they fix this bug?

(Reported behaviour experenced with LibO V4.2.3)

edit retag flag offensive close merge delete

Comments

Would you mind to tell what locale you actually worked in?
Would you mind to tell what your 'Date acceptance patterns' field contained exactly?
Would you mind to tell if you actually had entered a space between the X and the 1?
All this is information needed by the next user visiting this thread to judge if it is relevant for him. Communities are not one-way.

Lupp gravatar imageLupp ( 2017-07-31 13:23:24 +0200 )edit

Having used up about 1 hour with this I can tell:
(I hvave no V4.2.3 - the V posted in a comment below - still at hand.)
With V4.2.8 Portable (which I had preserved for special reasons). I actually got the above reported behaviour under the default settings created by choosing the 'Slovak' or the 'Polish' locale. It was a bug!
I cannot tell which version first got fixed the bug. Recent versions (oldest one tested was V4.4.7) don't show it.

Lupp gravatar imageLupp ( 2017-07-31 13:33:17 +0200 )edit

Nobody should delete this topic. It may be helpful for another user who sticked to an older version.
This was not an autoformat and not a AutoCorrect issue but one of bad "recognition" of special input as dates.

Lupp gravatar imageLupp ( 2017-07-31 13:40:23 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-07-31 09:04:22 +0200

Why do people always call their ignorance the software's bug?

LibreOffice converts user input to dates based on cells' locale and settings located in Options-Language Options-Languages (Date acceptance patterns). You may change them as it fits you. Btw: you didn't mention neither version of LO, nor OS, nor your locale to be able to assist you further.

edit flag offensive delete link more

Comments

The OQer seems to work with a Polish locale. Date acceptance pattern M Y will then cause the described behaviour if the space also is entered.I cannot find a way to get the "recognition" work without the space, however. But why should a questioner disclose all his secrets to us?

Down with that silly localitis! It only helps to perpetuate stubborn sticking to bad practice - and to induce puzzling problems with general purpose software pretending to support the "simple user"..

Lupp gravatar imageLupp ( 2017-07-31 09:33:17 +0200 )edit

Using common and uniform patterns universal for all users over the world could make our lives better and simpler... if only users agreed :) I see too much users insisting on their right to use unreadable local letter sequences instead of unreadable English letter sequences (e.g. in Calc functions) - e.g. on grounds of less layout switches. Since 5.3, Russian localization started to include Calc localized function names because of that. Sigh...

Mike Kaganski gravatar imageMike Kaganski ( 2017-07-31 09:39:35 +0200 )edit

Other than that, we have localized format specifiers characters. Decimal/thousands separators are locale-specific; and also for some locales, the format keywords themselves (e.g. HH, MM) are localized, too! This makes e.g. TEXT function unportable!

But we live in real world. And there is no one great authority here who might pretend to know the Ultimate Good solution to everyone's requirements. C'est la vie.

Mike Kaganski gravatar imageMike Kaganski ( 2017-07-31 09:43:00 +0200 )edit

There is no ask.libreoffice.org.ru to date as far as I know. Did you worry about https://listarchives.libreoffice.org/... Will serve the demand? Yes, there surely are forums in Russian/Cyrillic ... Ukrainian? Will they be lively enough. How many contributors?
There are branches for Spanish, Italian and German. Have a look into them.
I sometimes refuse to search for German function names when I answer in ...de.
Questioners understand nonetheless. A miracle?

Lupp gravatar imageLupp ( 2017-07-31 09:55:58 +0200 )edit

Personally I don't care too much about local ask sites; I prefer answering in locale-independent way, and overall, my duties are more developer-related. I only support in my spare time. So, all these locale-specific issues are more of a hobbyist observations and wishes :)

Mike Kaganski gravatar imageMike Kaganski ( 2017-07-31 10:03:35 +0200 )edit

Similar with me. Except that I'm not a developer, and not only disregard locales a far as possible, switch off 'AutoCorrec' ..., but also argue against the ways "l10n" goes.
Even having set Esperanto as my locale I didn't manage to get a 4-digut-year into the default date format (which is ISO extended otherwise). German norming authority made ISO 8601 extended the standard. LibO ignores. The 2-digit-mess ("Y2k") is long forgotten....
There are 253 equally idiotic locales in V5.4.0.3 now.

Lupp gravatar imageLupp ( 2017-07-31 10:35:49 +0200 )edit

Can I safely delete this whole question topic since Mike helped me fix this and it's no longer needed?

cpy gravatar imagecpy ( 2017-07-31 13:01:03 +0200 )edit

I suppose you can. Good to hear that you solved your issue!

Mike Kaganski gravatar imageMike Kaganski ( 2017-07-31 13:02:21 +0200 )edit
0

answered 2017-07-31 10:01:04 +0200

cpy gravatar image

updated 2017-07-31 12:59:32 +0200

So here's version: Windows 7 64bit LO: Version: 4.2.3.3 Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff

Options-Language Options-Languages (Date acceptance patterns) yes I know about this, i tried changing it but what pattern X1 matches? D.M.Y;D.M.;D. M.;D. M. Y;D. M.;D. M. Y does not seem to match any. Happens in English or Slovak settings in autocorrect. I have disabled all options in all tabs in autocorrect. I use English locale.

My ignorance? If it's my ignorance then, why so many people complain about auto format of date?

Update to 5.4.0.3 fixed my problem thanks Mike!

edit flag offensive delete link more

Comments

The main reason why I mentioned ignorance is inability to ask good questions. I described what you omitted in your question in my comment; and even then you didn't tell your locale in your answer. I only have to guess that @Lupp is right in his assumption.

And only given your information (version), and Lupp's guess (locale), can I see that 4.2 did have a problem absent in later versions. So no, "they" will not fix what is already fixed.

Mike Kaganski gravatar imageMike Kaganski ( 2017-07-31 10:12:31 +0200 )edit

And users will always have questions WRT locale-specific topics, e.g. on grounds described by @Lupp. And also on any non-trivial topic in life. And there will always be people that like things that drive you nuts. So the mere fact that something gives rise to multiple questions doesn't make something a bug per se.

Mike Kaganski gravatar imageMike Kaganski ( 2017-07-31 10:14:36 +0200 )edit

I tried doing really everything but I couldn't find anything other than LO devs are disconnected from reality and simmilar style of answers to this date auto format topic, me disabling autocorrect didn't do anything so after lot of frustration I decided to post question where I got answer that it was fixed with an update. I didn't think it would help so I'm doing it right now.

Updating fixed my problem thanks Mike!

cpy gravatar imagecpy ( 2017-07-31 12:51:31 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-07-31 08:55:42 +0200

Seen: 42 times

Last updated: Jul 31 '17