Ask Your Question
3

Screen painting is slow, scrolling is over-aggressive, overall operation is slow and sometimes jerky

asked 2017-08-03 20:53:40 +0200

Just-a-user gravatar image

updated 2017-08-08 07:10:07 +0200

Screen painting is slow enough to be observed. Single, two or three mouse clicks on page-up and page-down areas on the scrollbar cause numerous page-up or page-down reactions, leading to scrolling well past the intended location and ongoing struggle to go to a desired location in Calc and Base (not Writer).

Just upgraded (using downloaded installers) from LibreOffice_5.2.3_Win_x86 to LibreOffice_5.3.4_Win_x64 (Version: 5.3.4.2 (x64), Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3 CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; Locale: en-US (en_US)). Operating system is Windows 7 64-bit. The prior version of LibreOffice was uninstalled before the newer version of LibreOffice was installed. I'm using a notebook computer with trackpad, all special features disabled except tap to click.

I had just started using Base with its native database engine and found scrolling to be over-aggressive. Clicking the scrollbar's line-down or line-up arrowhead worked fine, but a click or two (whether with the mouse's physical button or with a touchpad tap to click) on the scrollbar's page-up or page-down area would result in numerous page-up or page-down reactions, scrolling well past the intended destination, with scrolling taking place with significant delay. The database would often scroll near or to the bottom, or near or to the top. Navigation through the database was clumsy. Luckily, neither Calc nor Writer were affected.

So I upgraded to 5.3.4. Now screen painting is noticeably slow overall; Base continues to scroll over-aggressively as described; and Calc shows this type of over-aggressive scrolling, too. The overall slowdown feels sluggish, and gets especially bad when View > Data Sources is used to access a table from Calc, a table with about 100 records and 10 fields. Writer is slower to paint the screen, too, but it does not exhibit the over-aggressive scrolling behavior.

To get Calc to work faster I have started a new profile; I have unchecked the selection for using the Java runtime environment; I have increased the image cache to 512MB, memory per object to 15MB, and number of objects to 75 (I do not embed graphics in my documents or database); I have disabled OpenGL (later re-enabled it); I have allowed use of OpenCL (with and without OpenGL, later disabled it); and I have made sure not to start other applications. Slow screen painting and over-aggressive response to mouse page-up and page-down click events continue and no improvement is observed.

Screen painting is sufficiently slow that, when going through Tools > Options, you can watch the individually selected windows "unfurl", you can experience the window get populated with its UI elements. Graphics acceleration has been on throughout. Slow screen painting affects Calc throughout its operation. It also has an observable effect on Writer. Applications other than those in LibreOffice are not affected.

What would you like me to try to help isolate the cause? What can I do to restore the speed of screen painting speed of LibreOffice 5.2 ... (more)

edit retag flag offensive close merge delete

15 Answers

Sort by » oldest newest most voted
0

answered 2017-08-08 08:48:17 +0200

paravantis gravatar image

updated 2017-08-08 08:49:06 +0200

I do not face this problem on my Windows 10 x64 laptop (and write this to help narrow down the issue).

When I had a similar problem (too sluggish response, very slow screen refreshing program windows etc.) with Blender 3D (a few months ago), I found out it was the nVidia graphics driver, so would you please confirm that LibreOffice is running on Integrated Graphics (if you have a separate graphics card)?

If you do have a separate graphics card, would you then try running it on your the nVidia (or whatever exclusive graphics card you have) driver, and report back the result? If relevant, please make sure the graphics card driver is updated.

edit flag offensive delete link more

Comments

Notebook computer with Intel HD Graphics 4000 display adapter. Drivers are updated with Windows Updates, when needed. No other application shows this slowness. Thanks for the suggestion, it just doesn't seem to apply in this case. Something else is going wrong, and many others are experiencing something similar and posting their own questions.

Just-a-user gravatar imageJust-a-user ( 2017-08-10 11:23:06 +0200 )edit
0

answered 2017-11-16 16:24:44 +0200

Ben_lb gravatar image

updated 2017-11-16 16:32:29 +0200

Same issue here.

Win10 64bit with NVidea Graphics GTX 1060

Recently upgraded to 7.4.2.2 and since then Calc has been slow to draw page.

Version: 5.4.2.2 (x64) Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4 CPU threads: 6; OS: Windows 6.19; UI render: GL; Locale: en-GB (en_GB); Calc: group

edit: Just updated manually to 4.3.2 and the issue is resolved. The auto updater didnt suggest the new version though?

edit flag offensive delete link more
0

answered 2018-02-02 07:53:27 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Solved the problem. got the solution from here https://askubuntu.com/questions/77627...

edit flag offensive delete link more
0

answered 2019-08-10 03:15:50 +0200

dwarka gravatar image

In Microsoft Mouse and Keyboard Center, select your device, and then select Basic settings. Depending on the mouse model you are using, select Wheel or Touch Strip. Select Identify programs that don’t scroll correctly.

edit flag offensive delete link more

Comments

@dwarka , to prevent you to spam all requests adressing this scroll issue with a possibly very limited solution for only a few users:

1.) Microsoft Mouse and Keyboard Center is only available for users of a Microsoft Keyboard or Mouse. In a Windwos 7 / 8 / 8.1 / 10 without that there is no option for this. As well not in Linux.

2.) Most of the requests deal with the use of a touchpad, not scrolling with a mouse.

Cookievore gravatar imageCookievore ( 2019-08-10 12:14:29 +0200 )edit
0

answered 2017-11-17 23:03:11 +0200

Just resolved my same issue completely. If you do a custom install instead of the typical try uninstalling then reinstall using the typical option. That may clear it up. If not everything i did was uninstalled x64 custom install; installed x86 typical install; uninstalled; installed x64 typical. Was like night and day in performance. Seems either something doesn't get installed or the ui is looking for something in the languages i had unchecked for a leaner install.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

4 followers

Stats

Asked: 2017-08-03 20:53:40 +0200

Seen: 6,685 times

Last updated: Aug 10