Ask Your Question

Copy/Paste from LibreOffice 4 to Internet Browser [closed]

asked 2013-02-11 17:30:36 +0100

Meme gravatar image

updated 2015-10-21 16:40:32 +0100

Alex Kemp gravatar image

Hi. I've been using Microsoft Office 2009 since it came out, and I thought I'd try LibreOffice 4 to see how well "free" is before buying an upgrade to MS Office 2013 when it comes out.

I like it so far, but one thing bothers me. I work online, and I have to copy content from my Office program into my Firefox browser. When I do this with MS Office 2009, it's fast and easy. When I try it with LibreOffice 4, I have to hit Ctrl-V to paste like five times before it pastes the content into the browser.

Why does it lag so much? Surely this is an issue with the program and maybe some conflicts on my computer. I tried again with MS Office 2009 and no lag.

Can someone explain why it would do this and how I could fix it. I'd like to keep using LibreOffice, but if it does this, then I have no choice but to continue using MS Office 2009.

Thank you very much.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-21 16:41:51.911915


I have had a similar problem just now. I cannot paste text from LibreWriter to the body of a Gmail email. No delays, it just does not do it.

I found a workaround, which is to paste text in Notepad and then copy / paste it from Notepad to Gmail.

Please let me know if there is a solution without having to use Notepad. I have LibreOffice 4.2.


Giuseppe gravatar imageGiuseppe ( 2014-03-01 16:42:33 +0100 )edit

I have had this problem in many versions now. When I inspect the clipboard using it seems that there ton of more data to choose from, when pasting and my suspicion is that the application to paste into can't make sense of the data. There are differences in CF_Text and the EOM_Text values, a ton of HTML formatted text and embedded data.

The more I think of it, my guess is that Notepad is testing for embedded data, and since Write is storing the text as such, Notepad just gives up.

Gnurk gravatar imageGnurk ( 2014-07-08 10:26:07 +0100 )edit

3 Answers

Sort by » oldest newest most voted

answered 2013-02-11 20:16:27 +0100

qubit gravatar image

Hi @Meme,

I just tested pasting content from LO4 into Firefox, and the response was very snappy. I'm testing on Ubuntu 12.04, so perhaps you're experiencing something different on your Windows (?) machine.

Quick test: Try copying and pasting the text using your mouse (Right click -> Copy; Right click -> Paste). If that works faster for you, there might be an issue with the way that your application or OS is processing keystrokes.

In any case, please feel free to file a bug report. Include information about what OS and version of Firefox you're using, as well as what you're pasting the content into online (e.g. the search box, a GMail compose-new-email text box, etc...).


edit flag offensive delete link more

answered 2013-02-12 03:09:54 +0100

Meme gravatar image

It does it from LibreOffice 4 to Notepad. In LibreOffice 4, I write "All I want for Christmas is you." I cut it from there and paste it into Notepad. It doesn't do anything. So I paste again. Nothing. Then I paste again, and it finally works. There seems to be some kind of delay between the two programs, whether I'm pasting into another Windows program or the web browser.

I'm on Windows 7 64-bit, and using Firefox. I can post a bug report, but at this stage, I think I'd be better off going back to MS Word.

Thanks a lot for your help though.

edit flag offensive delete link more


I have not had delay pasting in gmail from LibreOffice with Ctrl-C and Ctrl-V (Win 7x64 Ultimate). You can try to reset the user profile, sometimes solve strange issues.

m.a.riosv gravatar imagem.a.riosv ( 2013-02-12 03:24:44 +0100 )edit

I have no delay at all copying Writer to Notepad (Win7 prem 64bit).

horst gravatar imagehorst ( 2013-02-12 03:44:47 +0100 )edit

What the heck.. could it be my Avast antivirus or Zone Alarm firewall in the background? It's happening for a reason.. something is up. I tried resetting my user profile. I still have the same problem.

Meme gravatar imageMeme ( 2013-02-12 04:05:53 +0100 )edit

Have you try deactivating some of them temporarily?

m.a.riosv gravatar imagem.a.riosv ( 2013-02-12 13:02:31 +0100 )edit

Do you have more than one antivirus running?

horst gravatar imagehorst ( 2013-02-12 22:12:25 +0100 )edit

I don't have any other antivirus other than Avast and I turned off my firewall and antivirus to see if it would help, but no luck. I used Word today with no problems. I even tried the portable LibreOffice 4 to see if that would help, but I get the same delay on copy paste.

Meme gravatar imageMeme ( 2013-02-12 22:33:13 +0100 )edit

Hi @Meme, I'd still be interested to see a bug report about this, even if you do decide that LO isn't working out for you right now. That way if another user has the same issue, they'll know that they're not the only one to see it! Thanks! :-)

qubit gravatar imagequbit ( 2013-02-14 22:26:56 +0100 )edit

answered 2013-02-12 04:24:42 +0100

ROSt52 gravatar image

@Meme I made a test using LibO Version (Build ID: 5b93205) on XP Prof / SP3 and didt crtl+c and ctrl+v and followed additionally the advice from qubit using mouse right clicks to copy & paste. In both ways, I do not observe any delay.

edit flag offensive delete link more

Question Tools


Asked: 2013-02-11 17:30:36 +0100

Seen: 1,543 times

Last updated: Feb 12 '13