Ask Your Question
0

How can I prevent LibreOffice from offering fonts not on my system? [closed]

asked 2013-02-13 01:05:09 +0200

updated 2013-02-13 01:15:25 +0200

I recently installed GNU TeXmacs and removed it immediately thereafter. The uninstallation did not remove the fonts that the program had installed, so I removed them manually, but LibreOffice is still seeing them and it's annoying to have to scroll through them. No other programs are seeing the fonts, and this problem was not fixed by reinstalling LibreOffice.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-21 18:17:36.485670

3 Answers

Sort by » oldest newest most voted
1

answered 2013-02-13 01:42:59 +0200

qubit gravatar image

updated 2013-02-13 05:59:44 +0200

Hmm... interesting!

Are you sure that the fonts are completely removed from your system? If you're on a unix-y system, you can try to use the following to ferret-out any copies that may still remain:

locate <fontname-or-fontname-prefix>

For example on my system, I can find all of the copies of the Arimo fonts that I have installed:

qubit@loopbackoffice:~/on/a/magic/carpet/ride$ locate Arimo
/usr/share/fonts/truetype/googly-web-fonts/Arimo
/usr/share/fonts/truetype/googly-web-fonts/Arimo/Arimo-Bold.ttf
/usr/share/fonts/truetype/googly-web-fonts/Arimo/Arimo-BoldItalic.ttf
/usr/share/fonts/truetype/googly-web-fonts/Arimo/Arimo-Italic.ttf
/usr/share/fonts/truetype/googly-web-fonts/Arimo/Arimo-Regular.ttf

If the fonts really are removed from the system, it's possible that LibreOffice is caching a list of available fonts somewhere. Perhaps the system fontlist needs to be nudged, or there's some config file in LO that needs to be tweaked.


Update:

Q: Can you still use the fonts in documents, or are they just appearing in a list of available fontfaces?

Regarding "nudging" the font cache, Trisquel is based on Ubuntu, so it's likely the information here will work for you:

In particular, to update the cache, try the following command:

sudo fc-cache -f -v
edit flag offensive delete link more

Comments

I'm really sorry about this...I didn't check this in any other programs... gedit and Firefox still seeing the fonts, so this probably isn't a LibreOffice problem. Yet curiously, Font Manager isn't seeing the fonts, and I based my statement on that assumption. (I am using Trisquel 5.5.)

Uglyface200 gravatar imageUglyface200 ( 2013-02-13 05:14:24 +0200 )edit

In any case, I'm not seeing the fonts when I use the "locate" command, so how can I nudge this system fontlist?

Uglyface200 gravatar imageUglyface200 ( 2013-02-13 05:19:28 +0200 )edit

No, I cannot use them. They are just names with no fonts attached, and switching to them crashes LO.

Uglyface200 gravatar imageUglyface200 ( 2013-02-13 17:11:52 +0200 )edit

Updating the font cache worked. Thank you!

Uglyface200 gravatar imageUglyface200 ( 2013-02-14 01:09:10 +0200 )edit
0

answered 2013-02-13 20:06:17 +0200

qubit gravatar image

Hi @Uglyface200,

We've been unable to reproduce your issue when testing (LO 4.1.0.0.alpha0+ on Bodhi Linux, another Ubuntu derivative):

Here are the repro steps we took:

  • Installed a new font
  • Deleted from /usr/share/fonts
  • Updated cache, no longer in LibO

Here are some more things you can test:

  1. Please double-check /usr/share/fonts again to make sure that the are no lingering font files (maybe duplicates were installed?).
  2. You can try searching for the font like this (if locate isn't updating properly):

    sudo find / -name FONTNAME.ttf
    
  3. Update the font cache (per my previous Answer) -- make sure you run w/root privs (e.g. sudo)

  4. Reboot, to make sure that all of the applications have a chance to re-initialize their font list from what's on disk.

If all of this doesn't work, please file a bug. If the problem is affecting more than just LO, please file against Trisquel:

Otherwise, if only LO is showing the problem, please file a bug report against LibreOffice.

Either way, if you do file a bug with either project, please post a link to it in a comment below. LibreOffice bugs can use the format "fdo#123456", but you'll have to use the entire URL for a Trisquel bug :-)

Thanks!

edit flag offensive delete link more
-1

answered 2013-02-13 08:37:22 +0200

jiero gravatar image

LibreOffice shall hide all fonts except most used ones to save user time when choosing fonts. Also prevent rendering lag.

edit flag offensive delete link more

Comments

This is not an answer to my question at all.

Uglyface200 gravatar imageUglyface200 ( 2013-02-13 17:09:53 +0200 )edit

Question Tools

Stats

Asked: 2013-02-13 01:05:09 +0200

Seen: 988 times

Last updated: Feb 13 '13