Ask Your Question
0

LibreOffice 4.0 CMIS integration [closed]

asked 2013-02-13 03:06:52 +0200

mbnoimi gravatar image

updated 2015-08-28 10:05:06 +0200

Alex Kemp gravatar image

Hi,

As I read LO 4.0 supports CMIS integration. I want to know how can I do that with Alfresco?

PS

  • I'm unable to access to youtube.com so please don't link to it.
  • I can easily do it in 3.6 version by enabling experiment options & default LO dialogs. now I can't find them in LO 4.0
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-29 16:13:41.682110

Comments

This isn't a duplicate post... It related to alfresco and asks clearly don't use youtube links

mbnoimi gravatar imagembnoimi ( 2013-02-13 03:07:51 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-02-18 12:12:37 +0200

Arie Skliarouk gravatar image

The CMIS integration works, you need to set up the CMIS binding. These are possible to define only if you enable "Use LibreOffice dialogs" in Tools->Options->LibreOffice->General.

After you do that, you can go into File Open Dialog (File->Open) and click onto tiny ellipse button (Connect to server). Set name of the server, choose type "CMIS", Server Type "Alfresco 4", put in server name, choose repository.

I am still yet to learn how to make Alfresco's "Edit online" button on documents to launch LibreOffice. Please write in comments how to do that (if possible).

edit flag offensive delete link more

Comments

I'm not sure what if "Edit online" button will launch LO or not because it needs browser plug-in to make it run.

mbnoimi gravatar imagembnoimi ( 2013-02-23 14:32:15 +0200 )edit
0

answered 2013-04-08 15:42:23 +0200

I'm working in Windows (XP) and having no success at connecting with Alfresco. I get different responses when I click on the button next to the Repository drop box. Sometimes I am asked for a master password, sometimes - most of the time -- nothing happens. I put in "localhost:8080 the binding url. Once I tried changing the http to https. That time, I got asked my signing info for Alfresco. Does CMIS not work on XP? Is there another problem? What am I missing?

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-02-13 03:06:52 +0200

Seen: 5,542 times

Last updated: Apr 08 '13