Ask Your Question
1

Calc cell style background colour uses only the default palette

asked 2017-08-08 19:14:36 +0200

crlMIDI gravatar image

Version: 5.3.5.2 (x64) W10, French

I updated the version just now, because of the very recent introduction of more subtle colour palettes.

However, in styles and formating, only the standard palette is presented for selecting the background colour of a named cell style, though the full choice of palettes is available for the border colour.

I'd like to know if this is the current state of development or if I should I report this as a bug.

border background

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2017-08-08 20:22:52 +0200

Regina gravatar image

That is work in progress. The bug https://bugs.documentfoundation.org/s... collects the places, which are currently missing.

For Calc you can use the workaround, that has worked since the beginning: Add a shape to the spreadsheet. Click on item "Area..." in its context menu. Change the palette there. Go back to the cell and open the cell formatting dialog. Now the new palette is available there too. When you do not need the shape any longer for changing color palettes, delete it.

edit flag offensive delete link more

Comments

Thanks for your quick reply.

The workaround also works when creating and modifying named cell styles, which are needed for conditional formating.

Recently-used colours are not shown, which isn't a problem if I have remembered to note down their parameters or make a shape for each!

crlMIDI gravatar imagecrlMIDI ( 2017-08-09 10:12:23 +0200 )edit

For some reason the workaround isn't working 100% for me. I had to add the colour in question as a custom palette (it had been part of the Document Palette originally), and even then, applying it to a document style made it slightly off-shade (from hex #ccffcc to #ccf4c6). Reapplying it doesn't make any difference. Seems like the background colour selector might be restricting the palette to "websafe" hues?

libreoffiguess gravatar imagelibreoffiguess ( 2018-11-05 21:27:24 +0200 )edit
0

answered 2019-07-10 19:28:47 +0200

updated 2019-07-10 19:30:20 +0200

Another workaround is to Update the style with a color

Steps

1) Define a new Style with any color. In this case, we leave it at "No fill" because we will be changing it later

default color

2) Set the new Style to a cell. In this case we set it to an entire row.

image description

3) Change the color of the cell to the color you want for the Style. In this case we set it to 150, 150, 150 in RGB.

image description

4) The color of only that cell will change

image description

5) Finally, while positioned it that cell, click on "Update Style" to update the color of the style.

image description

6) The color has been assigned to your Style and all the cells with said style have been updated. In this example, the whole row changed color.

image description

edit flag offensive delete link more

Comments

Nice and smart; but the workaround is not required since version 6.2.

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-11 04:10:33 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2017-08-08 19:14:36 +0200

Seen: 531 times

Last updated: Jul 10