Ask Your Question
1

In Base - text field is displayed as number

asked 2013-02-13 18:12:23 +0200

Mike Pike gravatar image

updated 2015-08-30 00:18:42 +0200

Alex Kemp gravatar image

A database sub-form has text fields which displayed correctly until about a month ago. Now they appear as 0 (number zero) unless they contain a number - it appears to be number format even though the table column is defined as datatype [VARCHAR] and the column in the sub-form is defined as text format. This is true of all such columns in sub-forms even though nothing has changed in the design (Version 3.3.4.1 - updated to 3.6.4.3). Is there a workaround please?

edit retag flag offensive close merge delete

Comments

Is it just me then? Further to this, I have upgraded to version 3.6.5.2 and created a new test form using the wizard and default settings. I based the form on another table in the same database with a range of datatypes. The [VARCHAR] fields display in the form as numbers instead of text.

Mike Pike gravatar imageMike Pike ( 2013-02-23 23:33:23 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-03-30 01:00:50 +0200

Mike Pike gravatar image

Seems to have been a glitch. It was the table that was affected, not the form. Somehow all the VARCHAR columns had been changed to an inconsistent format:- in the "Field Properties" section of the Table Design dialog, the "Format example" showed "0" which doesn't make sense for a VARCHAR. Clicking on the ellipsis to open the "Field Format" dialog, showed expected values - Category "Text", Format "@" and Format code "@". Clicking "Reset" in this dialog did not have any effect. The data displayed correctly in the Table Data View, it was only in a Datasheet Form based on the table where the data was displayed in an incorrect format (matching the Format example but not VARCHAR).

So the answer? I eventually changed the format of the affected columns to something else and then changed back again. The system complained that the column "could not be modified" and offered to remove and append but I clicked "No". However the Format example was now showing the expected "@" so I clicked Save and was very surprised that it allowed me to save the table and the database and all is now well!

This is still my original LO version 3.3.4.1 and jre 1.6.0_22. No idea how this anomaly arose and of course I can't now reproduce it.

edit flag offensive delete link more

Comments

1

Had the same problem, thanks for solution. I switched the fields to the VARCHAR_IGNORECASE and back, so didn't get the complaint about modification. This was with V4.1.4.2

nigelmercier gravatar imagenigelmercier ( 2013-12-21 17:35:49 +0200 )edit
0

answered 2014-09-24 19:37:24 +0200

Here is my symptom :

I just came across this very same problem today, with LO 4.2.6.3 running on Ubuntu 14.04. The problem I had was that on one machine (setup in French), everything was displayed properly; on another machine (setup in English), text in subform tables was displayed as '0' (zero) or as a number if the string happened to contain a number somewhere in it. On the first machine running a different user (setup in English), same problem as with the second machine.

I realized that this problem is linked to the language the underlying table is defined with. It is not linked to the language or your OS, or the language for LO.

Here is my fix :

  1. On the machine on which the text is being displayed properly, I edited the table : for each text field, I clicked on the ellipsis and checked the language (French in my case).
  2. I repeated the process on the machine that doesn't display the text properly, and noticed that the language in the table definition had been altered to English (maybe because that machine is setup in English?), so I set it back to French. I repeated this for every TEXT field in my table, and saved the table definition.

This solved my problem across all of my machines.

Do pay attention to the fact that you could be experiencing this problem because your table could be defined in en_UK when you'd be tying to display it on an en_US, or any other en_* system.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-02-13 18:12:23 +0200

Seen: 1,265 times

Last updated: Sep 24 '14