Ask Your Question
0

CALC: Auto recalc does not work.

asked 2013-02-15 10:06:32 +0200

East69 gravatar image

updated 2013-02-15 14:44:34 +0200

I use my old ods file years ago. The formulas recalc does not work a few weeks ago. If I press F2 to edit the formula and at the end of the formula I press a SPACE then ENTER it works. One example:

C2 D2

3000 =C2/423

When I edit C2 and press ENTER, D2 cell shows wrong value. But if I edit D2 and I press SPACE (so I modify the D2 VALUE ) Calc can calculate the good value. F9 works but I think I should not have to use F9 all the time.

edit retag flag offensive close merge delete

Comments

Which version do you use?

moggi gravatar imagemoggi ( 2013-02-15 12:31:16 +0200 )edit

Did D2 show the formula or a (wrong) result before you entered editing mode?

Lupp gravatar imageLupp ( 2015-02-26 20:09:45 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2013-06-15 02:33:56 +0200

razon_22 gravatar image

You mention that you're using an older file from years ago. LibreOffice intentionally does not recalculate older spreadsheets, because as formulas are updated from version to version or between different spreadsheet programs, the results can be different. Go to Tools – Options – LibreOffice Calc, under 'Recalculation on file load', change the two drop-downs, 'Excel 2007 and newer' and 'ODF Spreadsheet (not saved by LibreOffice)', to 'Always recalculate'. Click Ok, close the spreadsheet and LibreOffice. Now open the file in LibreOffice and you should see that the formulas have recalculated.

Also go to Tools – Cell Contents and be sure that AutoCalculate is selected.

edit flag offensive delete link more

Comments

It worked for me, great thanks! Add: Restart the LibreOffice when it doesn't auto recalculate after changing.

nfrozi gravatar imagenfrozi ( 2018-01-16 10:54:34 +0200 )edit

The location of where the final options are has changed. I don't know which version it started with, but in 5.3:

  1. still go to Preferences: LibreOffice Calc or (guessing for windows) Tools: Options: LibreOffice Calc
  2. then Formula
  3. There you'll find both Recalculation on File Load options mentioned above.
Damon gravatar imageDamon ( 2018-11-02 13:57:07 +0200 )edit
0

answered 2015-10-27 20:16:05 +0200

fsr gravatar image

I had this problem with a specific spreadsheet, and it was fixed by saving as a copy in xls format, then opening the xls in libreoffice and saving as .ods again. Maybe "save as a copy" would also work saving in .ods directly, but i didn't tested it.

edit flag offensive delete link more
0

answered 2015-02-26 15:13:19 +0200

Dear Support,

Still having similar problem Version: 4.4.0.3. This is my case: B10= number, data for these formula C10= formula: =IF(IFERROR(B10,0),1,0) D10= formula: =SUM(C8:C12) E10= formula: =SUM(D8:D12) And those cells copied to B1:B20 The result: ONLY the col C that changed by input or edit the cell in col B. NO changes in col D and com E, related option already been set.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-02-15 10:06:32 +0200

Seen: 14,491 times

Last updated: Feb 26 '15