Ask Your Question
0

Unable to add two-word expressions like "et al." to dictionary

asked 2017-08-12 19:02:58 +0200

paravantis gravatar image

updated 2017-08-13 09:05:41 +0200

In LibreOffice 5.4.0.3 x64, I cannot find a way to make the spell checker learn the "et al." expression that I often use in research texts when citing papers with more than three authors.

Is there a way to add such two-word expressions to the dictionary? If not, I am thinking of submitting this issue to Bugzilla as a possible improvement.

I may be missing something due to my inexperience with this wonderful program.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2017-08-12 19:53:37 +0200

librebel gravatar image

Hello @paravantis,

please try the following approach:

  1. select the phrase "et al." in your document,
  2. right-click inside the selection and choose "Character..."
  3. in the dialog that pops up, in the box "Language", select "Latin".
  4. Then click OK.
edit flag offensive delete link more

Comments

Thank you @librebel, for taking the time to help out.

Your suggested method does indeed help stop "et al." being marked as a spelling error.

It would be more convenient if I could add this expression to the English dictionary.

So, is there a way to add such two-word expressions to the English dictionary?

paravantis gravatar imageparavantis ( 2017-08-12 20:19:04 +0200 )edit

I think only as 2 separate words .. just right-click on the word that has a red wavy underline, and select the menu item "Add to Dictionary".

librebel gravatar imagelibrebel ( 2017-08-12 20:28:05 +0200 )edit

Thank you, I thought so, and it's too bad because I don't want the dictionary to think that any instance of "et" and "al." is right.

paravantis gravatar imageparavantis ( 2017-08-12 20:38:42 +0200 )edit

Strangely, if you select the phrase "et al." ( using Language= English (USA) ) and then click the menu "Tools : Thesaurus...", it suggests "et al" without a dot. So the phrase is recognized after all, only the punctuation matters...

librebel gravatar imagelibrebel ( 2017-08-12 21:21:50 +0200 )edit

Confirmed!

paravantis gravatar imageparavantis ( 2017-08-12 21:26:51 +0200 )edit
0

answered 2017-08-13 08:18:06 +0200

ajlittoz gravatar image

Since these abbreviated expressions (et al., i.e., e.g. and others) are from a different language than main text (they're Latin as pointed out), typographical rules require they are displayed differently, usually in italics.

For the double purpose of silencing spellchecking and visual cue, I use a dedicated character style with Language attribute set accordingly (or to None if I merge all foreign quotations in a single class) and the desired appearance.

Of course, this is less "comfortable" than implicit recognition because you must set character style before typing the expression and reset it to default afterwards. But all your foreign expressions are now under full control should you need to change their appearance in a single shot, without tracking every individual occurrence.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-08-12 19:02:58 +0200

Seen: 38 times

Last updated: Aug 13