Ask Your Question
0

Libre Excel read only. [closed]

asked 2012-03-15 23:07:10 +0200

bobgroome gravatar image

updated 2015-10-18 18:58:42 +0200

Alex Kemp gravatar image

Opening an 2010 Excel (created on a PC) with Libre 3.5.1. Made sure 'read only' flag was off. But when open, Libre says it was opened as read only. Tried with Liber "read only" flag on and got same result.

Mac Intel, OSX 10.6.8

Suggestions?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-18 18:59:32.287419

6 Answers

Sort by » oldest newest most voted
1

answered 2012-09-24 19:44:02 +0200

Sudhanshu gravatar image

there is a button on the second row of your menu over which if you hover your mouse it'll say Edit file. Just click on this button and it'll prompt for the password which was assigned by the author to lock editing. Once you enter correct password it'll be unlocked for editing.

edit flag offensive delete link more
0

answered 2012-10-24 19:21:59 +0200

Hello, First of all I want to thank Sudhansu, who wrote 24/9-12: "there is a button on the second row of your menu over which if you hover your mouse it'll say Edit file. Just click on this button and it'll prompt for the password which was assigned by the author to lock editing. Once you enter correct password it'll be unlocked for editing." I'm not exactly sure if I found this button, however, I found that if you let the mouse hover the symbol of a sheet and a pencil, located on the 2nd row of the menu (that is, the first row of symbols), the fifth symbol from the left. If it says "Edit file" make a right click on the mouse, and you will be asked if you want to save a copy. Say "Yes" and there you go- a copy of the original document, except this time you can edit it:)

edit flag offensive delete link more
0

answered 2012-03-16 14:11:09 +0200

Are you sure that the file is not WriteProtected?

If it is you find the option to unprotect it at Extras->Protect Document.

edit flag offensive delete link more
-1

answered 2012-06-08 00:16:15 +0200

shdawson gravatar image

File has a password. LibreCalc is not prompting for the 2nd password. Enter that, with the Edit File button. It accepts it. Still showing file as read-only.

File permissions are: user@host$ ls -la

..... -rw-rw-rw- 1 dude dude 3444224 May 20 11:31 calc for mom.xls .....

Hmmm.......need to determine why this is not allowing edit mode.

-S

edit flag offensive delete link more
-1

answered 2012-06-06 03:28:23 +0200

shdawson gravatar image

Hi,

Having the same problem. I have 3 workbooks from Excel that I built. Opening them for the first time in Libre Excel. They opened OK. However, one of them is opening Ready-Only. I checked file permissions. Some were set to read only, not read and write. I closed Libre Excel and opened again. Still getting Read-Only upon opening the file.

What is wrong, please?

Thanks, SHD

edit flag offensive delete link more
-1

answered 2012-06-06 15:53:20 +0200

shdawson gravatar image

Took a shot this morning. Opened the file, again as ready-only. Did a save as. It took a bit, but it saved and now is not ready-only. Error message saying, "All Basic code is lost, but code is saved a VBA." Is there something in this workbook that is causing it to be forced to read-only?

Please advise.

Thanks, SHD

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-03-15 23:07:10 +0200

Seen: 19,390 times

Last updated: Oct 24 '12