Ask Your Question
1

How to end autoformat bold and underline? [closed]

asked 2013-02-16 21:20:12 +0200

matt_b gravatar image

updated 2015-10-26 19:50:03 +0200

Alex Kemp gravatar image

I used to love the ability to bold and italicize text without removing my hands from the keyboard, but in recent versions of LibreOffice when I surround text with asterisks or underscores to bold or underline text using autoformatting, the bold/underline continues after the closing character. This completely defeats the purpose, since I now have to remove my hands from the keyboard to turn off bold/underline.

Is this a bug, or is there an option or setting to remedy this that I'm overlooking?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Alex Kemp
close date 2015-10-26 19:50:16.308187

Comments

@marisov: Thanks for the tip about Ctrl-M. That does at least provide one solution to the problem. However, it still seems like the closing asterisk or underscore should end the bold or underline (which it used to do). Using another keystroke to do this shouldn't be necessary.

matt_b gravatar imagematt_b ( 2013-02-17 00:45:14 +0200 )edit
1

@qubit: I've filed a bug report (fdo#62536). It does seem to be a state-based bug, since as you said it starts behaving as expected if I (immediately) use the toolbar to toggle the formatting.

matt_b gravatar imagematt_b ( 2013-03-18 22:33:13 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2013-08-07 23:09:48 +0200

manj_k gravatar image
edit flag offensive delete link more
0

answered 2013-02-16 22:12:13 +0200

m.a.riosv gravatar image

I do not know if it is a bug but may be Ctrl+M can serve to recover your previous format.

edit flag offensive delete link more
0

answered 2013-03-12 01:13:03 +0200

qubit gravatar image

Hi @matt_b,

(testing on LO 4.0.0.3 + Ubuntu 12.04.2)

I can confirm that using asterisks to bold a section of text does not seem to work as it should. Repro steps

  1. Open LO Writer
  2. Type the following verbatim:

    I hid the *pitchfork* in the silverware drawer


RESULT: The text displays like this:

I hid the pitchfork in the silverware drawer


EXPECTED: The text to display like this:

I hid the pitchfork in the silverware drawer

I see the same issue with underscores for underlining.


WORKAROUND: Could you try using Ctrl-B and Ctrl-I to toggle Bold and Italic on/off from your keyboard?

NOTE: This might be some kind of state-based bug. Once I toggle-off the formatting via the GUI or using a keystroke (e.g. Ctrl-B), the end character (*, _, etc...) will correctly close a section of formatted text. This persists until the document is closed.

In any case, this is definitely something QA should take a look at! Please file a bug and provide a list of steps that can reproduce your problem (Please feel free to steal mine -- just make sure to include that NOTE :-). The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more

Comments

As @matt_b mentions above, BUG FILED as:

  • fdo#62536 - FORMATTING: Closing autoformat for bold/underline character doesn't end autoformatting - UNCONFIRMED
qubit gravatar imagequbit ( 2013-03-19 19:20:37 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-02-16 21:20:12 +0200

Seen: 3,743 times

Last updated: Mar 12 '13