Ask Your Question
-1

=CONCATENATE(text1;text2;....) riddle

asked 2017-08-17 11:33:28 +0100

catscratch gravatar image

So, why don't you remove this if you can't make it work ?

All cells are TEXT, I write =CONCATENATE("wtf";"mate") it shows the formula. I fill A1 and B1 with WTF and MATE and put =CONCATENATE(A1;B1) in C1, it shows the formula.

So did you ever find out what's wrong with the function ?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2017-08-17 12:54:12 +0100

Lupp gravatar image

updated 2017-08-17 13:01:17 +0100

The villain may also be the '@' format code ('Text') set under 'Numbers' for the cell.

I probably didn' find something "wrong with the function" because I used it properly in calculating cells under appropriate settings.

BTW1: "wtf" and "mate" aren't cells but constant texts.
BTW2: There is not only the CONCATENATE function, but also the infix operator & for concatenation. A simple formula like =A1 & A2 might be preferable compared with =CONCATENATE(A1; A2)
BTW3: Also try TEXTJOIN if your LibO version is V 5.3.x or higher. Unfortunately there isn't yet a useful helptext for the function. If using the function wizard: Tex1 and the following parameters also accept ranges and calculated arrays (needing array-evaluation in the last case).

BTW4: It's often the users with their first and only question using insults and showing a lordly attitude. I cannot remember a case where such a user later also posted useful help for others. They don't understand the community nature of forums. (So, why should they understand the software which is much more complicated?)

edit flag offensive delete link more

Comments

Good catch; possibly that's what OP meant with "All cells are TEXT"

Mike Kaganski gravatar imageMike Kaganski ( 2017-08-17 12:58:57 +0100 )edit

I just select the cells and set the category the text. Yes there's @ as Format Code. But how is it my fault ? When I remove @, it says User-Defined. So it needs to be User-Defined not text :D That's why i'm angry. It's not a COS/SIN formula, its a simple text combining function I just needed to use after so many years of not using excel sheets.

catscratch gravatar imagecatscratch ( 2017-08-17 13:35:32 +0100 )edit

Yes there's @ as Format Code. But how is it my fault ? ... That's why i'm angry. ... its a simple text combining function I just needed to use after so many years of not using excel sheets

Not knowing how to use software properly isn't somebody's fault. It may be frustrating - to try to recall how it was done many years ago.

But bashing on unknown people because of one's ignorance is somebody's fault.

Mike Kaganski gravatar imageMike Kaganski ( 2017-08-17 14:40:52 +0100 )edit

Generally use 'General' (in some locales 'Standard' ... ) if there is not a specific reason to do otherwise. A cell having a text result, whether entered directly or returned by a formula will always remain text.
Yes. It's irritating that cells must be set to a numeric format to be able to calculate their formulae. It's a probably bad, but surely very old design decision. Nobody here is responsible for it and nobody in the world can change it now, I'm afraid, without getting lynched.

Lupp gravatar imageLupp ( 2017-08-17 15:02:42 +0100 )edit

So it needs to be User-Defined not text :D That's why i'm angry.

You may erroneously assume deleting the '@' is the way. You should not assume everybody to make the same assumption. Stay cool and consider alternatives. Otherwise you will fail with any software again and again.

Lupp gravatar imageLupp ( 2017-08-17 15:07:11 +0100 )edit

Very good points, in addition there is also the =CONCAT function, which allows a cellrange as argument:

=CONCAT(A1:A2)

librebel gravatar imagelibrebel ( 2017-08-17 18:14:49 +0100 )edit

Quoting @librebel; "...the =CONCAT function, which allows a cellrange as argument:"
Thanks for the hint, and: =TEXTJOIN("";1;TheTextSequenceList) should be equivalent to =CONCAT(TheTextSequenceList).

Lupp gravatar imageLupp ( 2017-08-17 21:05:04 +0100 )edit
0

answered 2017-08-17 11:40:48 +0100

The proper way to answer this insulting question is:

So, why don't you hold your hands out of keyboard if you can't RTFM?

But I'll refrain from this kind if answer, and instead suggest that you have somehow turned the "Show Formula" mode on, which is located in View menu. Uncheck it, and cells should no more show the formulas, but their results instead.

edit flag offensive delete link more

Comments

I just learned about "Show Formulae" and guess what, it was already unchecked. I'd never touch that setting anyway.

catscratch gravatar imagecatscratch ( 2017-08-17 13:19:16 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-08-17 11:33:28 +0100

Seen: 90 times

Last updated: Aug 17 '17