Ask Your Question
0

Some Italian keyboard characters do not type!

asked 2017-08-18 21:07:50 +0100

dougWB gravatar image

I am using English Windows 10 64 bit, English Libre Office (ver 5.2.6.2 x64) with Italian keyboard. Some characters (namely @ # [ ] { } €) cannot be typed in Writer from the keyboard although they type correctly in others apps e.g. Notepad, Edge, I.E., Calc, Impress, etc. My laptop is set up correctly for English Windows & Italian keyboard. How can I get these characters to type?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-08-18 23:53:31 +0100

m.a.riosv gravatar image

Do you have Italian on Menu/Tools/Options/Language settings/Language - Locale settings.

edit flag offensive delete link more

Comments

Locale was set to English (UK) but changing this to Italian (Italy) does not help e.g. pressing Ctrl+Alt with + produces nothing - it should give ] (right square bracket)...... note that this keyboard press works in this window (Edge browser)! Thanks for the suggestion.

dougWB gravatar imagedougWB ( 2017-08-19 09:06:34 +0100 )edit

Please try resetting the user profile, sometimes solves strange issues. https://wiki.documentfoundation.org/U... Usually it's enough renaming/deleting the file "user/registrymodifications.xcu", it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.

m.a.riosv gravatar imagem.a.riosv ( 2017-08-19 12:42:56 +0100 )edit

I reset the user profile as suggested but the problem is still there! Interestingly I reset the Locale to Italian (Italy) and the Default Languages for documents - Western automatically became Italian (Italy); unfortunately that didn't help either - nor did resetting this back to English (UK).

dougWB gravatar imagedougWB ( 2017-08-19 15:29:16 +0100 )edit

And restart the computer?

m.a.riosv gravatar imagem.a.riosv ( 2017-08-19 18:59:20 +0100 )edit

I didn't restart the computer but, having done so, the problem is still there.

dougWB gravatar imagedougWB ( 2017-08-19 23:35:22 +0100 )edit

Please take a look if any of https://bugs.documentfoundation.org/b... bugs is siimilar. If not please report a new one.

m.a.riosv gravatar imagem.a.riosv ( 2017-08-20 01:20:12 +0100 )edit

Thanks for that. I did find a similar bug affecting LO Writer - No. 100908 "Ctrl+Alt+? for AltGr toggle does not work" - Status: NEW. Ctrl+Alt+ .... should work in Writer as it does in other apps but, after reading the bug report, I found that AltGr does the same job as Ctrl+Alt !!!! So I can get the required characters: i.e. AltGr+5 > €, AltGr+ò >@, AltGr+à >#, AltGr+è >[, AltGr++ >], AltGr+Shift+è >{ & AltGr+Shift++ >}. The bug is there but there is an easy way around it.

dougWB gravatar imagedougWB ( 2017-08-20 19:09:06 +0100 )edit

Does it work with English layout?

m.a.riosv gravatar imagem.a.riosv ( 2017-08-20 23:09:09 +0100 )edit

IF, under Tools/ Options/ Language Settings/ Languages, you set all the following entries to "English (UK)": User interface, Locale setting & Default Languages for Document - Western THEN all of the above keystrokes work (this is, of course, with English Win10 64bit set to match my Italian keyboard). I bought the laptop with Italian keyboard because it was a bargain for such a high spec machine.

dougWB gravatar imagedougWB ( 2017-08-21 18:22:18 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-08-18 21:07:50 +0100

Seen: 57 times

Last updated: Aug 18 '17