Ask Your Question
0

How do I show numbers bigger than the cell?

asked 2017-09-06 01:35:09 +0200

rkkn gravatar image

updated 2017-09-06 02:30:26 +0200

When text is larger than the cell, it either is cut off or flows into the next cell if the next cell is empty. That's what I want my numbers to do, too. But instead, they are hidden by "###". How do I fix this? And no, I don't want to resize the column. I want it to behave like text does: either only show part of the number or spill over into the next cell.

It seems like something that should be incredibly simple, but I couldn't find it on Google.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2017-09-06 02:00:44 +0200

robleyd gravatar image

In the column header, drag the right hand border to make the cell width as you want it; or, right click in the column header and choose Optimal Column Width

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

I don't want to resize the column. I want it to behave like text does: either only show part of the number or spill over into the next cell.

Edited this clarification into question

rkkn gravatar imagerkkn ( 2017-09-06 02:27:20 +0200 )edit
0

answered 2017-09-06 06:36:13 +0200

JBF gravatar image

Change to number format so that it fit in the cell. With scientific format you can choose the number of digits to be shown.

edit flag offensive delete link more
0

answered 2017-09-06 06:34:44 +0200

updated 2017-09-06 07:24:13 +0200

It's not something "incredibly simple". It's impossible. Calc doesn't work like that. It can continue text to the cell to the right (in LTR), but only if the cells to the right have absolutely no data and formatting. No way to wrap text to cells below.

You can clip though, if you use Format cells-Alignment-Wrap text automatically.

EDIT: I missed the "numbers" in the topic title, and thought about the "text" as written several times in description. If that data in cells are numbers, then even clipping is impossible.

edit flag offensive delete link more
0

answered 2017-09-06 10:22:29 +0200

Lupp gravatar image

updated 2017-09-06 10:24:12 +0200

The only workaround I know usable for contents and results of type number in the same way is 'Format Cells...' > 'Alignment' > 'Shrink to fit cell size'. High screen resolution, good eyes and strong glasses sometimes required.

Another way (I would dissuade from) requires different handling of constant numeric content and of formula results:
Constant numbers: Enter with a single apostrophe prefixd (telling Calc not to recognize type 'Number'). Formula results: Pass the result to the TEXT() function as its first parameter with an appropriate code string (may be "General" e.g. in English based locales) as the second parameter.
In both cases the display will overflow into blank adjacent cells depending on the alignment of original cell. For many choosable number formats the (otherwise disputable) automatic conversion will allow to still use such contents or results as operands in formulae.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-09-06 01:35:09 +0200

Seen: 288 times

Last updated: Sep 06 '17