Ask Your Question

Can't change style for only one paragraph, entire document changes. [closed]

asked 2017-09-08 23:51:30 +0200

DonaldN gravatar image

Brief description... I use Jotterpad on my tablet for Bible studies. I make comments and input scriptures, it saves in txt. Then I go to my desktop and open the .txt file to format it in Libre Office. When I highlight a single paragraph and try to change the style the entire document changes, I hit undo and the entire document is highlighted. The same happens if I copy\paste from and internet source also. It won't let me format anything input from other sources.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-10-15 11:03:00.513042

4 Answers

Sort by » oldest newest most voted

answered 2017-09-10 08:20:57 +0200

ajlittoz gravatar image

To give a more comprehensive answer than @gabix's, LO Writer is based on so-called styles. With regard to text, two categories are concerned:

  • paragraph styles define the basic appearance of the whole block
  • character styles override the former for a designated run of characters

You can add to that manual formatting which overrides in its turn the previous styles.

Note that manual formatting is highly discouraged because its usage is "invisible" and hides the changes you make to paragraph and character styles.

Importing raw text from a .txt file results in paragraphs with style Default Style. If you modify this style, all such styled paragraphs will reflect the change. LO Writer was designed for that: this allows an editor/reviewer to quickly and comfortably tune the way text should appear according to in-house typographic or graphical rules.

Think of paragraph and character styles as semantic marking. Don't hesitate to define styles to declare what's is inside your paragraphs and/or highlighted runs of characters. Only then fix the graphic attributes of styles (font type, size, boldness, roman/italics, color, margins, space above/below, ...).

For example, if you have a style named Caution, setting text color to red, all Caution paragraphs will turn red at once. This is what happened to you in your single-styled document.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

answered 2017-09-10 10:44:54 +0200

updated 2017-09-13 18:55:21 +0200

I suppose that you can also misuse the "style" term for manually formatting paragraph settings. In this case, it's possible that the text you open (a TXT file) has line end marks that LibreOffice takes for line breaks, not paragraphs. In this case, you effectively have one single paragraph in your document in LibreOffice, with line breaks. So, when you apply a paragraph properties, it applies to whole single-paragraph document.

To check if your document have one or multiple paragraphs, enable non-printing characters display (View-Formatting marks, Ctrl+F10) and check that your lines end with paragraph break (¶), not line break mark (↵).

To make sure that you have line ends treated as paragraph breaks in your file, use File-Open..., select the file, select Text - Choose Encoding file type, and then click Open.


Then try to select different values in the Paragraph break group of ASCII Filter Options dialog.

edit flag offensive delete link more


I checked and do indeed have line breaks rather than paragraph breaks. However, I don't find your way of changing this..."use File-Open..., select the file, select Text - Choose Encoding file type, and then click OK." Can you elaborate on this for me please.

DonaldN gravatar imageDonaldN ( 2017-09-13 18:11:53 +0200 )edit

answered 2017-09-09 17:57:22 +0200

gabix gravatar image

That is what should be. That is what styles are for. You should either apply manual formatting to a particular paragraph or create a separate style.

edit flag offensive delete link more

answered 2017-09-11 00:33:30 +0200

m.a.riosv gravatar image

Maybe 'AutoUpdate' is enable for the style.

image description

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-09-08 23:51:30 +0200

Seen: 1,369 times

Last updated: Sep 13 '17