Cant change TOC's Contents Font

asked 2017-09-13 11:18:59 +0200

nickabbooo gravatar image

Hi. Im trying to customize the style of content of my TOC (generated through Insert > Table of Contents and Index. But when i try to change the font by right-click on the contents > Styles > Edit Style... > Font Tab, the contents wasn't changed. Even if it show my preferred font is selected in "Family" font list.

The weird thing is, when i try to change "Style" (Regular, bold, etc.) or "Size", it changed accordingly.

Is this a bug? Or my step to change the font is wrong?

I'm using LO Writer V5.4.0.3.

edit retag flag offensive close merge delete

Comments

Can't reproduce: it works for me. Have you tried the "regular" way by modifying the various Contents x (where x is the level in the TOC, the counterpart to Heading x) styles in the style panel? This should be the same, but who knows?

ajlittoz gravatar imageajlittoz ( 2017-09-14 08:35:55 +0200 )edit

LO Writer 6.0.5.2 I have mixed fonts in the ToC -- Liberation Serif and Liberation Sans. I want them all the same, Sans. The dividing line seems to be that I first created the ToC (I have deleted and re-created it several times) prior to editing the Default Paragraph style to be Sans. Any Headings (H1 and H2) that were in the document before the style change are appearing in the ToC with the original Default Paragraph font, Liberation Serif. H3, added after the style edit, are Sans. ????

tmm13 gravatar imagetmm13 ( 2018-09-13 17:13:33 +0200 )edit

UPDATE. As the document was not lengthy, I created a new, empty one. Before adding any text to the new one, I changed the Default Paragraph font to Liberation Sans. After cutting and pasting the source text, but re-creating the Headings, the ToC behaves correctly.

tmm13 gravatar imagetmm13 ( 2018-09-13 18:18:37 +0200 )edit