Ask Your Question
0

Why does the LibreOffice installer default to input language?

asked 2017-09-24 12:50:45 +0200

Becks gravatar image

Hi,

I'm a Windows 10 x64 user. My Windows system language is English (United States), my location is set to United Kingdom, my system locale is set to English (United States), because I prefer, nay, I demand, that the UI on my PC follows english language. My native language however, is Norwegian, and my keyboard is Norwegian, so I have set my input language to Norwegian. However, whenever I try to install LibreOffice, the installer defaults to Norwegian, despite all language settings indicating that English should be the system language. Why is this? Is there such a thing as an English-only installer?

And yes, I realize that I can probably change the UI language after installing LibreOffice, but it makes absolutely no sense that it should prioritize input language over system language or system locale. That would be the equivalent of approaching a random person on the street in London, and expecting the person to speak Norwegian, just because he happens to carry a bottle of "Voss" water...seeing as it's a Norwegian brand. It makes absolutely no sense.

Perhaps I'm being pedantic, but why would the software not follow system locale, and rather choose to follow input language?

And please take this inquiry seriously, as I'm not trying to troll or be malicious, I'm just trying to understand this (perhaps to most people insignificant) issue.

Sincerely,

Rebecca Schade

edit retag flag offensive close merge delete

Comments

This site can help you with specific problem about using LibreOffice, but we can't help you about developement decisions as thous are collected/tracked at Bugzilla - there you should file enhancement request so developers can look into it. But hardly this to be omission or lapse, probably there's a reason for this. Good luck.

Kruno gravatar imageKruno ( 2017-09-24 14:57:48 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-09-24 22:59:15 +0200

floris v gravatar image

I'm not entirely sure, but this is probably a Windows problem. I'm Dutch, but I always had an English keyboard with dead keys attached to my Windows computers. Despite that, for many years and Windows versions, Windows insisted that I had a Dutch keyboard, and would select Dutch as input language in, IIRC, Word as well as in OpenOffice. Quite annoying, because the key mappings of ;:,.' and " are very different for English and Dutch keyboards. I finally solved the problem by setting the Dutch keyboard to US (International). It seems that the Windows developers saw the light when working on Windows 10, where it was set that way by default.

edit flag offensive delete link more
0

answered 2019-04-29 12:32:36 +0200

On Windows, installer uses not "input language", but user locale setting, which is set using intl.cpl:

image description

(image from this blog).

This is because we build multilingual installer; and Windows Installer uses this setting, not UI language, when deciding which of languages available in the MSI to use. One may directly choose the installer UI language using a command line like

msiexec /i path\to\LibreOffice.msi ProductLanguage=1033

where 1033 is the decimal LCID for en-US.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-09-24 12:50:45 +0200

Seen: 114 times

Last updated: Apr 29