Conflict between latest Java JRE and LibreOffice plug ins

asked 2017-09-27 17:15:59 +0200

Der Alte Fritz gravatar image

I have Zotero stand alone version 5 and Libre Office Version: 5.4.1.2 (x64) running on Windows 10

The LibreOffice plugin stopped working at the last update and I have removed it from LibreOffice and then tried re-installing it again. Tried to install from Zotero download and then from within LibreOffice but by both ways I got this error message:

"Could not create Java implementation loader"

Progress report. 1) Checked LibreOffice Java Options = no JRE showing 2) Downloaded same from Java site = http://www.oracle.com/technetwork/jav... but during unpacking there was an error! 3) Downloaded complete file from Java site and installed without need for unpacking. 4) Shut down LibreOffice 5) Restarted and checked to see if JRE appeared on list. It does not. Tried to find folder but LibreOffice did not like any folder that I found. 6 Uninstalled everything and tried re-installing it all, latest versions. Does not work.

Second Try: Right success. 1) Uninstalled everything 2) Installed Java JRE_1.8.0_144 3) Installed LibreOffice 5.3.6.1 x64 (latest stable conservative user) 4) JRE appears in Java Option list 5) Zotero plugin works 6) Able to add endnote references to documents using plug in and standalone Zotero

So looks as if JRE-9 does not work with Zotero plug in for LibreOffice

edit retag flag offensive close merge delete

Comments

@Der Alte Fritz You information is most welcome. It turns out Java 9 affected other parts of LibreOffice as well - see Bug #112551. Reported there to be fixed in releases 5.3.7 and 5.4.2

Ratslinger gravatar imageRatslinger ( 2017-09-28 23:12:53 +0200 )edit