Ask Your Question
0

Issues with Table of Contents [closed]

asked 2017-09-29 02:56:59 +0100

aarontimo gravatar image

Hi there,

I'm having some trouble formatting the table of contents for my dissertation that I would appreciate any help in resolving:

  1. Level 3 (and onwards) headings do not appear in my table of contents (on navigation bar). When I 'edit index', under the 'create index or table of contents' subheading it is set to evaluation up to level 10, so I am very confused.

  2. Is it possible to increase the line spacing in a table of contents? I've tried edit index>entries>character style = default paragraph style, which is set to 1.5 line spacing, but it does not increase the line spacing.

  3. Is it possible to have a heading formatted in italics but for the heading not to be italicised in the table of contents?

Thank you in advance for your help.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by aarontimo
close date 2017-10-06 02:49:43.072238

1 Answer

Sort by » oldest newest most voted
1

answered 2017-09-29 08:51:25 +0100

ajlittoz gravatar image

updated 2017-10-03 17:54:20 +0100

  1. Check that the heading paragraphs have received paragraph style Heading x where x is 1 to 10. This is the default.You may have changed Heading x allocation to outline (chapter/section). Open Tools>Chapter Numbering (formerly Outline Numbering) and verify that all levels are associated with Heading x paragraph style. If this is no longer the case, report here and a procedure will be given.

  2. Entries in the TOC have their own paragraph style: as can be seen in the TOC dialog (accessed with right-click on the TOC and choosing Edit Index/Table), Styles tab, levels are associated to Contents x paragraph style. Just customise said style to format the level to your taste.

  3. As can be inferred from previous points, formatting headings and entries are independent from each other. Headings are controlled by Heading x styles while entries depend on Contents x.

EDIT 2017-10-3: (to answer question in comment about numbering formatting)

By default, numbering in headings is formatted the same as the whole paragraph. Since it is generated text, you cannot select it and apply a character style to it. However, this can be done.

Open Tools>Chapter Numbering, tab Numbering. Drop-down menu Character style assigns a character style to numbering. If it is set to None, Heading x (paragraph style) settings are not overridden.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Thank you so much! Issues 1 and 2 are fixed!!

In relation to (3), I have double checked the formatting for the entries in the Contents styles and it is set to 'regular', not 'italics'. The contents style is faithfully recreating the Heading style (which is a mixture of regular and italics). Is there something else I can try?

Thank you again!

aarontimo gravatar imageaarontimo ( 2017-09-29 10:23:54 +0100 )edit

Wrt (3): if you format your heading with character styles, they are removed when creating the contents entry. Only manual formatting is kept. Consequently, clear manual formatting from your headings and use only character styles, unless you want the manual formatting forwarded to the TOC entry.

Unfortunately, there is no way, in my knowledge, to add character styles in a TOC entry because this is not real text but generated text.

ajlittoz gravatar imageajlittoz ( 2017-09-29 16:13:45 +0100 )edit

Thank you very much! You are absolutely right.

This, however, has raised another issue which may be better as a separate post. The Australian Guide to Legal Citation requires level 2 headings that are numbered (not italicised) but the title to be italicised. Is this possible? I've been able to change the title of the heading in character styles to be italicised but then the numbering is italicised as well.

Thank you again for your help!

aarontimo gravatar imageaarontimo ( 2017-10-03 03:46:54 +0100 )edit

Leave all Other Idea THere Is Best Thing For table of content management just Check It Out This site

http://index-indent-online.com/

All Solution of table of content issue here!!

shashank gravatar imageshashank ( 2018-03-18 10:37:19 +0100 )edit

@shashark: I doubt this would be of any help when composing a book; you don't get automatic update to your ToC which must be recreated whenever you change anything.

ajlittoz gravatar imageajlittoz ( 2018-03-18 12:26:12 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2017-09-29 02:56:59 +0100

Seen: 1,705 times

Last updated: Oct 03 '17