Ask Your Question
0

Writer print orientation change

asked 2017-09-30 20:04:05 +0100

SkyCor gravatar image

LO version 5.3.6.1, on MacOS Sierra and on MacOS High Sierra. The Print function changes the orientation of the text. The original document is set to portrait as shown in Screenshot001.png: Screenshot001.png

When clicking on the print icon, the preview of the document still shows it is in portrait mode, but the text has shifted as if it were meant to be in landscape mode as shown in Screenshot002.png: Screenshot002.png

While still in the print screen, I selected "Save as PDF" from the lower left menu function. The pdf file generated has the text shifted as if in landscape mode, but the page is in portrait mode as shown in Screenshot003.png: Screenshot003.png

After exiting the print window, I selected the "Export as PDF" menu icon and the exported pdf file was as expected: the page layout and the text were all in portrait mode as shown in Screenshot004.png: Screenshot004.png

And by the way, for those of you on a Ketogenic diet, this recipe is delicious! ;-)

edit retag flag offensive close merge delete

Comments

Have you checked that printer is set to landscape as default? Printer settings and page format are independent from each other. For practical purposes they should be identical ;-)

ajlittoz gravatar imageajlittoz ( 2017-10-01 08:19:10 +0100 )edit

The only place I can find to change the orientation of the page is in the Format > Page menu. I haven't found a setting in the print menus where I can change the orientation. If I do a print preview, it shows the text correctly oriented in portrait mode. It's not until I open the actual print menu function that the text orientation changes, even though the display of the page still shows the paper in portrait mode. This issue never showed up before upgrading to LibreOffice 5.3.6.1

SkyCor gravatar imageSkyCor ( 2017-10-02 03:41:13 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-10-01 17:54:26 +0100

petermau gravatar image

updated 2017-10-02 10:56:42 +0100

Have you changed the PAGE STYLE to Landscape? If not, the page is still Portrait, and when you export it as a PDF, you are exporting the Portrait document. The print icon effects the printing on a physical printer, not the document itself.

On my Linux-Mint LibO system, right click on the document and select PAGE, the change the orientation. Details will differ on a Mac.

==============================================

There appears to be a bug related to this problem with American Letter Sized setting and Mac. https://bugs.documentfoundation.org/s... Comment 44 gives a suggested workaround for this problem. "Found a walkaround: only happens with letter size. If change to user format by .3 mm it doesn't do it, and it doesn't do it with any other format (ex:A4.) So changed default template to a user one just less than 1 mm different from letter size and the bug doesn't happen."

edit flag offensive delete link more

Comments

In my case, with exactly the same problem, the Format>Page settings are correct for Orientation (Portrait), but still prints sideways. This problem happens ONLY in Letter size—prints OK in A4 or Legal.

rjohn-mus gravatar imagerjohn-mus ( 2017-10-01 19:34:32 +0100 )edit

I changed the paper size to A4 and yes, the issue went away. As soon as I set the paper back to Letter, the issue came back. So there appears to be a problem with the paper size. Also, I have selected different printers just to see if the issue was related to a printer driver; the problem persisted.

SkyCor gravatar imageSkyCor ( 2017-10-02 03:49:57 +0100 )edit

I have exactly the same behavior with MacOS High Sierra. Changing page format to A4 works fine. With the page format as letter it shows the problem. Printing the same xxx.odt file from a linux box works fine in both formats A4 and letter.

glentrobfc gravatar imageglentrobfc ( 2017-10-08 15:19:54 +0100 )edit

Interestingly, I restored MacOS High Sierra to the point just before the emergency supplemental update for High Sierra with a time machine (full disk restore) and the 'bug' disappeared. I then ran the emergency supplement update and the 'bug' reappeared. Must be some strangeness in the interface between libreoffice print driver and the OS print driver, such as timing, that the latest OS update exposed. The test file (which also prints fine from linux) just consists of 3 lines of garbage.

glentrobfc gravatar imageglentrobfc ( 2017-10-09 00:49:12 +0100 )edit

Searching on printer orientation I found an easy fix/workaround on the mac going to system preferences and changing us letter size to A4 fixes it. I haven't gone back to the earlier time machine backup because it takes quite a bit of time. However, my guess is that the MacOS update changed that system preference from A4 to US Letter and enabled the bug in MacOS High Sierra

glentrobfc gravatar imageglentrobfc ( 2017-10-09 03:23:19 +0100 )edit

Thanks for digging into this and sharing what you've found!

SkyCor gravatar imageSkyCor ( 2017-10-10 22:25:55 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2017-09-30 20:04:05 +0100

Seen: 607 times

Last updated: Oct 02 '17