Ask Your Question
0

Why does the Text CSV filter not permit *.txt extensions?

asked 2017-10-09 02:07:39 +0100

Jim DeLaHunt gravatar image

Sometimes tabular data comes in tab delimited text files, with extension .txt. LibreOffice Calc has a convenient "Text CSV (*.csv)" file type entry. If you can get to this import function, it has options to recognise tabs as delimiters. However, the extension filter recognises only files with extension .csv. This makes it hard to open tab-delimited ext files in Calc straighforwardly.

People ask questions about this, e.g. "Open txt files in Calc" . The answers involve kludges and workarounds. On some systems there is a File name box, and you can click on the file entry to populate that box before clicking on the filter; this does not work on Mac OS X with LibreOffice 5.3 or 5.4.1. You can open a blank spreadsheet, then then open a text file with no Text CSV filter, and for some reason the text CSV import function appears. You can use →Sheet→Insert sheet from file…..

This is awkward. There seems to be demand for broadening the file type filter to be "Text CSV (*.csv, *.txt)".

Interestingly, OpenOffice.org has exactly this Text CSV filter, including \*.txt. And, the LibreOffice FAQ How do I open a tab-delimited file in OpenOffice.org Spreadsheet? What if I have a different type of delimiter?cites the filter as "Text CSV (.csv; .txt)". Maybe that's a carryover from OpenOffice.org documentation.

Was there an intentional choice to strip \*.txt from the Text CSV filter in LibreOffice? Or, is there a bug report about this omission, where we could express our support for adding \*.txt?

Observed in LibreOffice 5.4.1 and 5.3.4 on Mac OS X 10.11.6.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2017-10-09 05:34:43 +0100

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-09 02:07:39 +0100

Seen: 127 times

Last updated: Oct 09 '17