impress will not import mp4

asked 2017-10-13 06:08:37 +0200

ccurley gravatar image

updated 2017-10-13 06:12:07 +0200

Version: 5.2.7.2 Build ID: 1:5.2.7-1~bpo8+1 CPU Threads: 4; OS Version: Linux 4.9; UI Render: default; VCL: gtk2; Locale: en-US (en_US.utf8); Calc: group

I have a presentation I created several years ago, with two embedded MP4 files. It used to work. Impress now will not play the mp4s.

I started a new presentation, and tried to import them into the new one. Impress reports it does not support the file format. Same with the media player (Tools -> Media Player).

Both files play in VLC.

$ file *.mp4
cpp.navaho.tppf.mp4: ISO Media, MP4 v2 [ISO 14496-14]
we.were.warned.mp4:  ISO Media, MP4 v2 [ISO 14496-14]
$
edit retag flag offensive close merge delete

Comments

Does old presentation play with LibreOffice 5.2.7 (no importing to new presentation). I would try LibreOffice 5.3.6. Videos in Impress never quite worked for me on Debian (but didn't used them much). My be helpful: impress playing mp4

You probably don't have appropriate codec installed on operating system level. VLC has it's own set of codecs and that's why your files play in VLC and not in Impress.

Kruno gravatar imageKruno ( 2017-10-13 10:02:50 +0200 )edit

You should also change title as seams that you can import files, but they don't play.

Kruno gravatar imageKruno ( 2017-10-13 10:06:20 +0200 )edit

How do I tell which codec(s) I need, then? I understand that LO uses gstreamer. I have the following Debian packages installed:

gstreamer0.10-plugins-bad 0.10.23-7.4+deb8u2

gstreamer0.10-plugins-base 0.10.36-2

gstreamer0.10-plugins-good 0.10.31-3+nmu4+deb8u2

gstreamer0.10-plugins-ugly 0.10.19-2.1

Previous versions of LO have imported and played these MP4s successfully.

I can also play these with xine.

ccurley gravatar imageccurley ( 2017-10-25 05:38:25 +0200 )edit

I don't know what might be wrong as I don't use this feature very often. Can you try with 5.4?

Kruno gravatar imageKruno ( 2017-10-25 12:56:07 +0200 )edit