Ask Your Question
0

Rubies messes up line-spacing (when typing Japanese)

asked 2017-10-13 09:40:55 +0100

Rose O gravatar image

updated 2017-10-13 09:50:21 +0100

When I type a Japanese text and I put rubies (furigana) above some Japanese character (kanji)-words to make them readable (for my students), the line spacing gets messed up. The line spacing uses both the text and the rubies above it instead of only the basic text to measure the space between the lines. So some lines will be wide apart, while others will be closer together. I want to make the line spacing ignore the rubies above the Japanese characters (kanji). How can I do that in LibreOffice Writer? I would add a picture as example, but apparently I'm not allowed to do that...

edit retag flag offensive close merge delete

Comments

Export to PDF and open the result in a PDF viewer. Does the problem still show up? Perhaps you could post an example using Unicode characters or their code points so that we can reproduce the problem. Use Alt+x to show a character's code points. Also be sure to mention operating system and version of LibreOffice.

Jim K gravatar imageJim K ( 2017-10-13 17:22:18 +0100 )edit

@Jim K This is expected behavior. The problem has nothing to do with Japanese characters. See my answer.

KH gravatar imageKH ( 2017-11-02 02:33:54 +0100 )edit

@Rose O Did you try out my answer? If it worked, it would be great if you upvote and accept.

KH gravatar imageKH ( 2017-12-18 14:55:07 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-11-02 02:30:25 +0100

KH gravatar image

updated 2017-11-02 02:34:46 +0100

I assume you are using single, double, or proportional line spacing (which all act the same way AFAIK).

In that case, the solution is to use "fixed" line spacing. Select the relevant text and change the line spacing to "fixed", then increase the spacing until there is no difference between lines with ruby/furigana and those without. ("At least" might also work, though I haven't really used it.)

If you are happy with the results, you can reset the formatting (ctrl+m) and set it in the paragraph style (most likely Text Body) so that the entire document is spaced correctly. If you write in Japanese a lot, you may want to create a template.

A warning: fixed line spacing may cause small problems that will surprise you if you are used to proportional spacing. If you do have any trouble, try changing the line spacing back to confirm that this is indeed the cause.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-13 09:40:55 +0100

Seen: 99 times

Last updated: Nov 02 '17