Ask Your Question
0

Copy from Calc into text editor with spaces instead of tabs

asked 2017-10-13 12:29:12 +0200

to7m gravatar image

Hi all,

If I copy a text from a text editor into Calc, it asks what I want the cell separators to be (tab, space, etc), but that doesn't work the other way round so sometimes I have to replace all the subsequent tabs in a newly created text file with spaces. Is there a way to tell Calc to export cell separators as spaces instead of tabs?

Thanks, Tom

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-10-13 13:05:22 +0200

Lupp gravatar image

A workarount might be to 'Paste Special...' (Ctrl+Shift+V) with option 'Formatted text [RTF]' .
This way you get a table which you may select as a whole and 'Table' > 'Convert' > 'Table to Text' with (e.g.) a space chosen as the separator.
If you can get exactly your wanted result will depend on circumstances I don't know of.

edit flag offensive delete link more
0

answered 2017-10-13 17:53:45 +0200

Jim K gravatar image

updated 2017-10-13 17:59:05 +0200

@Lupp's answer will not produce a fixed width result. For example, this:

calc spreadsheet

Becomes this:

a  d
b c e

A better way is to go to File -> Save As and choose Save as type: Text CSV. Check Edit filter settings and then Fixed column width. The result:

a                     d          
b          c          e

Some text editors such as Vim can also do this. Copy and paste from Calc into Vim and then do :retabas described at http://vim.wikia.com/wiki/Converting_....

For more precise control, write a macro like https://superuser.com/a/121206/541756. That example uses Excel, but I've seen similar examples recently for LibreOffice.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-13 12:29:12 +0200

Seen: 299 times

Last updated: Oct 13 '17