Ask Your Question
1

How can I disable the use of standard ligatures? [closed]

asked 2017-10-17 22:28:58 +0100

rama gravatar image

updated 2020-10-17 21:57:10 +0100

Alex Kemp gravatar image

I'm using a fixed width font, and Libre Office Writer replaces some letter sequences with the standard ligatures:

fi ff

That's great in most cases but in the case of a fixed width font it looks terrible of course. How can I disable this?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-10-17 21:56:35.130985

1 Answer

Sort by » oldest newest most voted
2

answered 2017-10-17 23:00:42 +0100

RGB-es gravatar image

On 5.3 and later, just add ":-liga" to the font name. For example, if you are using "Libertinus Serif" define your style to use as font

Libertinus Serif:-liga

edit flag offensive delete link more

Comments

Unfortunately, this doesn't seem to work for Andika. Perhaps this fix only works with fonts that explicitly include such a switch? The documentation for the font doesn't list any such option.

KH gravatar imageKH ( 2018-06-02 08:33:55 +0100 )edit

@KH Andika is a Graphite font, not an OpenType one, so it needs different switches. BTW, I do not see ligatures on Andika.

RGB-es gravatar imageRGB-es ( 2018-06-02 09:59:46 +0100 )edit

Andika has ff/fi/fl ligatures. I think I see the problem now. This "liga" looks like some kind of standardized OpenType feature based on the MS website. Andika provides both Graphite and OpenType switches for its features, but if it was originally designed for Graphite, then I suppose that would explain why this one is missing.

KH gravatar imageKH ( 2018-06-04 04:07:26 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2017-10-17 22:28:58 +0100

Seen: 1,002 times

Last updated: Oct 17 '17