Ask Your Question
0

Different style for chapter number and heading

asked 2017-10-19 02:08:50 +0100

aarontimo gravatar image

Hi there,

I am having trouble formatting my headings so that the heading text is in italics but the autogenerated chapter number is not in italics e.g.

1.7 Outline

At the moment it is appearing as

1.7 Outline

I have tried Tools>Chapter numbering>Character style and changing it from 'none' to 'default paragraph' (which is not formatted in italics) but it doesn't make any difference.

Any help or suggestions would be gratefully appreciated.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2017-10-19 23:26:08 +0100

ajlittoz gravatar image

See the EDIT related to the same issue in my answer here

edit flag offensive delete link more
0

answered 2017-10-20 01:49:14 +0100

aarontimo gravatar image

Thank you @ajilittoz. The issue was when I would go to Tools>Chapter Numbering, tab Numbering and would change the character style from 'none' to 'List1Level2' and click 'ok' nothing would change.

So I went to the heading Styles>Styles and Formatting. In the side dialogue box that opens, went to the 'A' button (character styles) and found List1Level2 and right-clicked to modify the style. It was already set to regular but as I tried clicking through the other options (e.g. bold and italics) it updated. Only when I selected 'regular' again, that this time I could see in the preview screen that the numbering was no longer italicised. I think the formatting was just stuck and needed to be refreshed.

edit flag offensive delete link more

Comments

1

That's one of the tricky aspects of paragraph-character styles interactions: attributes are in fact 3-state, not 2-state as suggested by the display. Initially, they are not set, meaning the attribute in paragraph is used. When you click, you set it and when clicking again, you reset it. In these latter cases, the attribute is forced and its value overrides the paragraph one.

If you want to "erase" your modifications, you must click the Standard button to revert to initial state.

ajlittoz gravatar imageajlittoz ( 2017-10-20 07:52:00 +0100 )edit
0

answered 2017-10-19 12:01:53 +0100

pierre-yves samyn gravatar image

Hi

What works in my environment (win 7 & 5.4):

  • create a character style that applies italic
  • choose this style of character for numbering
  • change the character style to remove italics (style: regular).

Regards

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-19 02:08:50 +0100

Seen: 383 times

Last updated: Oct 20 '17