Ask Your Question
0

Clear direct formatting ignores Character Styles

asked 2017-10-24 00:55:35 +0200

LunixTheFirst gravatar image

If I am using a paragraph style, then I format part of it with a character style to highlight it (same font and font size, but a different color with italics, for example), then I change the paragraph style, the character style portion of the text is unaffected.

Ideally, I think the paragraph attributes should be applied to the character style, when "Clear direct formatting" (Ctrl-M) is invoked. Or, all character formatting could be removed, and the raw paragraph style selected could be used.

edit retag flag offensive close merge delete

Comments

The tool is not "Clear character formatting", but "Clear direct formatting", with "direct" opposed to "formatting with styles". As character styles are styles, the tool's behaviour is consistent.

Mike Kaganski gravatar imageMike Kaganski ( 2017-10-24 06:14:11 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2017-10-24 08:18:34 +0200

ajlittoz gravatar image

You must first understand how styles work.

Three layers are available and the shallower override the deeper.

The lowest level is paragraph style. As the name implies, you act on the layer by giving a style to a whole paragraph. You reset it by giving a "neutral" paragraph style, in principle Default Style, which, because of this usage, should never be modified or actively used in the document (unless you know what you're doing).

The second layer is character style. You act on this layer by giving a style to a selected range of characters. Contrary to more complex DTP programs like Quark XPress®, any character can receive only a single character style, the latest applied overriding the previous one. You reset the style to the paragraph style by applying character style Default Style.

This latter style is not a real style. You can't modify it. Its sole purpose is to remove any character style.

The top layer is direct formatting. You set attributes with the buttons in the toolbar(s) or their shortcut equivalent. They are erased with Format->Clear Direct Formatting or Ctrl+M.

I suspect this third layer was provided to avoid the burden of setting up a consistent set of styles for short one-shot documents and maybe also for "compatibility" (i.e. not upsetting users even if it is "wrong") with other text processors.

Every layer is independent from each other. Resetting one does not reset the others.

To answer your question about resetting character style:

  1. Select the paragraph content (e.g. quadruple click)
  2. Apply character style Default Style

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Voila! THANK YOU!

LunixTheFirst gravatar imageLunixTheFirst ( 2017-10-24 09:24:17 +0200 )edit
0

answered 2017-10-24 08:04:00 +0200

gabix gravatar image

updated 2017-10-24 08:04:57 +0200

As Mike Kaganski says, it is intended behavior. If you deem it illogical, feel free to file a bug report/RFE. If you want to remove style-based character formatting, right click → Styles → Default Character.

edit flag offensive delete link more

Comments

Bug reports already have been discussed and closed.
Different would be a report (RFE) for an extra feature/shortcut. (Well, that may exist too)
I've linked Ctrl+Shift+0 to the character style Default to do fast changes.

cornouws gravatar imagecornouws ( 2017-10-24 08:18:10 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-24 00:55:35 +0200

Seen: 1,802 times

Last updated: Oct 24 '17