Ask Your Question

highlight all the cells used for a calculation used in another cell? [closed]

asked 2017-10-27 10:52:48 +0100

Katex gravatar image

updated 2020-10-06 14:25:26 +0100

Alex Kemp gravatar image

That function was working fine till last update. Recently I realised that now is missing. When I simple do the click on the cell where there is a formula, instead like before system has highlighted all cells used for calculation , now I can see only displayed formula. Is there any solution how to get the highlight cell option activated again?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-10-06 14:25:55.840819

3 Answers

Sort by » oldest newest most voted

answered 2017-10-27 11:01:52 +0100

Katex gravatar image

Upss . I found the problem. Double click needs to be done on the cell with the formula, not on the top at the input box Now all is working fine

edit flag offensive delete link more


Yes, double-click continued to work. The formula bar way was broken in that regard in 5.4.2, and will be restored in 5.4.4.

So yes, you found the problem - in your initial question; and you found a workaround (not solution) - with your answer.

Mike Kaganski gravatar imageMike Kaganski ( 2017-10-27 11:04:38 +0100 )edit

answered 2017-10-27 10:56:23 +0100

Fixed in coming updates (5.4.4 and 6.0).

edit flag offensive delete link more


Sorry, but I have the same problem even when upgrading to v5.4.7.2

When selecting the Sum cell, the cell range that is being summed is not highlighted.

ifelsethenend gravatar imageifelsethenend ( 2019-01-18 22:52:37 +0100 )edit

It never worked by selecting a cell. You need to click in the formula bar.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-18 22:55:11 +0100 )edit

Oh, I see. So I have to go into 'edit' mode to see the sum cell range highlighted. The same as double clicking really, as I can't click any other cell until I exit the 'edit' mode with Esc.

So there is no way in Calc to just view the range by selecting the cell with the formula? That's surprising, as it's such an essential part of working with spreadsheets and has been working in Excel for ages.

ifelsethenend gravatar imageifelsethenend ( 2019-01-18 23:02:03 +0100 )edit

and has been working in Excel for ages

just tested Excel 2016, and simply selecting the cell does not highlight dependent ranges

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-18 23:07:42 +0100 )edit

I'm sorry, last I used Excel was v2010 before ditching MS Office. As far as I can remember it was possible to see the range highlighted with a light background color and a border for the cell range once you click the cell with the sum formula.

Anyway, is this feature found in later versions of Calc, and if not can you guide me to where I can suggest such a feature?

Thank you very much for your prompt replies by the way. Much appreciated.

ifelsethenend gravatar imageifelsethenend ( 2019-01-18 23:20:17 +0100 )edit

As I said, "It never worked by selecting a cell" (which implies, "it doesn't work that way in current versions, too").

Any enhancement requests are welcome at bug tracker.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-18 23:25:11 +0100 )edit

answered 2019-05-27 18:48:16 +0100

zp gravatar image

Hello, I'm having trouble with this as well, in one of my documents, it still works fine on certain sheets, but on others it doesn't work at all.

In a different document, it seems to still be working as expected on all sheets so I am wondering if it is a local option or setting somewhere which accidentally got toggled.

To activate it, what I usually do is click in the cell where the formula is, then click in the input bar to highlight the cells. This does not work anymore, the details of the formula are displayed in the cell instead of the results as before but in black text rather than colours, and no cells are highlighted in colour. I tried double-clicking in a formula cell, this does not work either. This is a really big problem for me.

Is there a setting somewhere to check? Or a keyboard shortcut?

I just upgraded to version from version 5something hoping to resolve this problem but it has not worked.

Thanks in advance for any help.

edit flag offensive delete link more

Question Tools



Asked: 2017-10-27 10:52:48 +0100

Seen: 1,771 times

Last updated: May 27 '19