Ask Your Question
0

How do I get LibreOffice to use the system font I have installed? [closed]

asked 2013-03-02 20:55:53 +0200

khoogeland gravatar image

updated 2015-10-26 01:09:02 +0200

Alex Kemp gravatar image

LibreOffice does not use the system font I have installed. I did check the right box in the option menu, but it changes nothing. This might have something to do with me using Windows 8. I had trouble changing the system font, and found that the only way to do this is to use font-substitution in the register. I replaced 'Segoe UI' with 'dyslexie' and it works on every aplication except LibreOffice. 'Dyslexie' is a special font designed for people (like me) who are dyslectic. I desperately need this font to work. Without it I feel like I am blind. It's a true type, so that should not be the problem, but if needed I also have a open font conversion. Would love any help.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-26 01:09:12.580732

2 Answers

Sort by » oldest newest most voted
0

answered 2013-03-02 22:07:07 +0200

qubit gravatar image

updated 2013-03-02 22:46:13 +0200

Hi @khoogeland,

I believe that LibreOffice can use the system fonts, and per chat w/QA, it seems like LO should be able to use them by default.

Question: Do you want to use this dyslexic-friendly font for the body of your text (editing documents, etc..), for the application menus and message boxes, or for both purposes?

You mention trying to fix this by tweaking something in the Options menu. Did you select your default font like this?

Tools -> Options -> LibreOffice Writer -> Basic Fonts (Western)

If LibreOffice can't use the system fonts by default, then that sounds like a bug. Do you have this issue on any other machine?

If this problem continues, please file a bug and provide a list of steps that can reproduce your problem. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more
1

answered 2013-03-03 04:39:12 +0200

ROSt52 gravatar image

@khoogeland - I came across most likely the same problem on XP/SP3 and LibO 3.6.5

I observerd that I cannot change within LibO the default font for Calc . Impress and Draw except for using Tools / Options / LibreOffice / Fonts and make there an auto replacement. I use this in Calc and Draw and it works fine. In Impress I created my own templates hand thus my font is inside the template.

In Writer you can do it the way @qubit explained it. I use there also my personal setting which are different from Calc. In Impress the default template comes with the same font as Calc and Draw did before I made aforemention replacement settings

With this I want to 1 - show you ways to set up each LibO Element with the font you need. 2 - confirm @qubit's statement that LibO can take over the system font.

Problem: I don't know where W8 stores the system font.(I even don't know it for XP) but there is plenty of information in the web http://www.forumswindows8.com/performance-maintenance/how-change-system-font-windows-8-a-5676.htm http://www.neowin.net/forum/topic/1097357-change-the-default-system-fonts-in-windows-7-8/ https://www.youtube.com/watch?v=n4KklOVSVxs

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-02 20:55:53 +0200

Seen: 2,844 times

Last updated: Mar 03 '13