Ask Your Question
0

German and Spanish special characters

asked 2017-10-30 19:24:36 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

The LibreOffice version is 5.4.1.2

The operative system is Kubuntu 17.10

When I want to type in LibreOffice Writer the German characters "ä, ö, ü, ß", or the Spanisch characters "á, ó, ñ", the input is ignored, as if I had not typed anything at all and the next letter I type is displayed.

As you can see here, I can type these characters perfectly well inside this browser and all other software.

Can anyone give me a helping hand please?

Thanks!

edit retag flag offensive close merge delete

Comments

Install the German and the Spanish keyboard layout as well. And also the language files so that automatic spellcheck does not mix things up ...

pkoron gravatar imagepkoron ( 2018-11-14 11:13:57 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-10-30 21:47:28 +0100

RGB-es gravatar image

updated 2017-11-01 11:27:55 +0100

I found a similar problem testing 6.0alpha on Plasma. Probably it's a problem with KDE4 integration (there is no Plasma5 integration yet). Try installing the GTK3 integration package with your package manager and then try running Writer from konsole with

SAL_USE_VCLPLUGIN=gtk3 libreoffice --writer

If this fix the problem, uninstall the KDE4 integration package and just use the GTK3 one.

EDIT: fixed the launch instruction

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-30 19:24:36 +0100

Seen: 109 times

Last updated: Nov 01 '17