Putting certain images into Writer results in image-sized black box

asked 2017-11-06 03:35:13 +0200

ramendik gravatar image

updated 2017-11-07 02:22:07 +0200

I am trying to place certain images into a Writer document. Other images work fine, but I can't seem to make these ones work - I just get a black box with the image's aspect ratio.

Sample image: http://www.ramendik.ru/pic-5-1as.bmp

These are BMP files made by an obscure conversion utility. They open fine in chrome and gwenview and gimp. Moreover. if I use imagemagick or gimp to convert to tiff or png, the problem persists!

After a conversion to JPG the images do display but JPG affects the quality. A Gimp conversion to PSD also fixes the issue, but not an ImageMagick conversion, and I'd really prefer ImageMagick because I have a lot of these images,

I would appreciate any hints on how to insert the images (preferably as they are or with an automatic conversion). Also, do I need to raise a bug?

EDIT: it looks like the image comes back if I set the brightness to 10% (it is at 0 when image is inserted). But for other images brightness is also 0% and they are normal. Still not sure what is happening.

EDIT. from Help > About:

Version: 5.3.5.2 Build ID: 30m0(Build:2) CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: kde4; Layout Engine: new; Locale: en-IE (en_IE.UTF-8); Calc: group

The system is Linux, namely OpenSUSE Leap 42.2.

I start Writer, click the icon to create a blank new file, go to Insert>Image..., and select this image. I see the image as a black rectangle. Resulting ODT file: http://www.ramendik.ru/blankimage.odt

edit retag flag offensive close merge delete

Comments

To reproduce, it's better to also provide a ODT where all settings are already made; and detailed steps to create it.

Also, in case it's actually reproducible, this most possibly should be reported as bug. But I cannot reproduce it with 5.4.3.2x64 on Win10. It's a pity you didn't tell your version/OS and other info from Help-About.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-06 04:44:28 +0200 )edit

Thanks, added the requested information.

ramendik gravatar imageramendik ( 2017-11-07 02:21:39 +0200 )edit

Reproduced with: Version: 5.4.2.2 Build ID: 1:5.4.2~rc2-0ubuntu0.16.04.1~lo2 CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; Locale: en-US (en_US.UTF-8); Calc: group

But not with: Version: 5.4.2.2 (x64) Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4 CPU threads: 4; OS: Windows 6.19; UI render: GL; Locale: ru-RU (ru_RU); Calc: CL

Please file a bug report.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-07 07:26:58 +0200 )edit

I could reproduce on OpenOffice 4.1.4 on LinuxMint 17.3.

The images only contain 2 colors, green and black. On XnViewMP (for Linux) and other programs you can change this to - let me say - 8 colors; the batch mode can do for a large range of images in one step. - This is a workaround, no solution.

The images increased from 5.0 kB to 18.1 kB disk space each.

Cheers

Grantler gravatar imageGrantler ( 2017-11-07 15:06:41 +0200 )edit

A command /path/to/ImageMagick/convert pic-5-1as.bmp -depth 8 pic-5-1as.png had shrunk it from 4958 to 677 bytes. And the image had inserted properly.

This is still a workaround. Please file a bug, this would allow to fix this.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-07 15:33:22 +0200 )edit
ramendik gravatar imageramendik ( 2017-11-14 05:22:45 +0200 )edit