Ask Your Question
0

how to force a default page size

asked 2017-11-07 23:07:48 +0200

schnedan gravatar image

Running on Linux, using german keybord layout and locale, everything works fine except libreoffice always uses us letter as default page size, but it should be A4. How to permanently change this behaviour?

edit retag flag offensive close merge delete

Comments

See https://bugs.documentfoundation.org/s....

What should be noted is that LibreOffice has an issue, when it behaves erratically if the locale is "Some_Locale (default)" (vs the same "Some_Locale" without that "(default)").

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-08 06:17:10 +0200 )edit

Thanks... looks exactly as the Problem I have here!

schnedan gravatar imageschnedan ( 2017-11-08 23:43:14 +0200 )edit

after re-reading the bug briefly, I found out that the supplied solution works, so problem solved. but it's trickey. Even a longtime - since StarOffice 3.0 - user like me wasn't able to find this trick by myself...

schnedan gravatar imageschnedan ( 2017-11-17 19:58:11 +0200 )edit

As described in the issue, you should check your paperconf settings. LibreOffice consults it on Linux in case when it is configured to use OS settings (i. e. default locale). If the paperconf gives letter, then it will be Letter obviously. IMO this is not a LO bug, but rather wrong system configuration. Of course, there's room for documentation improvement.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-18 10:22:02 +0200 )edit

Possibly related OS problem: https://bugzilla.redhat.com/show_bug....

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-18 10:40:04 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-11-07 23:39:44 +0200

ajlittoz gravatar image

updated 2017-11-07 23:40:56 +0200

Check your OS configuration in system settings. There is one related to printing in Country/Region, Language, tab Other (description valid for KDE; I can't check in GNOME on the current laptop because it has no printer configured). Sometimes the Page size in not in sync with the locale and must be forced to A4.

Verify (in the OS) your printer default configuration.

In LO, Tools->Options->Language Settings->Languages, make sure the Locale is the right one. If correction needed, exit LO after correction and reenter before next step.

Look for page size in page style Default Style. If it is not A4, then correct the default template. Search this site for how to.

Hope that helps

edit flag offensive delete link more

Comments

Locale in LO is correct, and als cups shows A4 as default for all printers... I will ask the archlinux IRC... maybe they habe a idea

schnedan gravatar imageschnedan ( 2017-11-08 21:15:01 +0200 )edit
0

answered 2017-11-07 23:39:47 +0200

Lupp gravatar image

Create a document of the respective class and define all its properties including the paper size, but also any named styles as you want them, and save it as a template of the class (odt > ott, ods > ots ...). Then call the template manager, import the template and define it as 'Standard' if wanted.

edit flag offensive delete link more

Comments

I will remember this a the last resort solution --> should work, but I want to solve the cause, not cure the symphtoms --> anyway thanks al lot

schnedan gravatar imageschnedan ( 2017-11-08 21:13:12 +0200 )edit

I assumed LibO would not "invent" a default paper size, but import it either from the settings made for the OS or for the driver of the system's default printer or a diferent printer or something of the kind.
On my system nothing ever assured "sync" of the paper size and the locale or the document language. Why should LibO perpetuate 'Letter' in USA locales e.g?

Lupp gravatar imageLupp ( 2017-11-08 21:47:06 +0200 )edit

don't know, locale looks good, other Programs show A4 correctly. So far LO is the only one doing it wrong as far as I noticed

schnedan gravatar imageschnedan ( 2017-11-08 22:24:18 +0200 )edit

Thanks for this clarification. It's surprising for me. Did you try with a virgin user profile already?

Lupp gravatar imageLupp ( 2017-11-08 22:27:18 +0200 )edit

you mean a new linux user? no I dont... should be the same as renaming the user/.config/libreoffice folder, right? does not change anything

also tested templates... create new writer document: US letter, create from template default: A4

OK, now I set template default as default in template manager... now a new dokuments is created with A4...

schnedan gravatar imageschnedan ( 2017-11-08 23:30:03 +0200 )edit

little add: with the "set template default as default in template manager" now writer is healed, but calc, impress & draw still come up with US letter

schnedan gravatar imageschnedan ( 2017-11-08 23:35:44 +0200 )edit

Each document type has its own standard template.

Lupp gravatar imageLupp ( 2017-11-08 23:42:26 +0200 )edit

so first, see post above - problem soved due tricky language setting in LO. But no, there are none, Calc and Draw have no templates in the template manager (not in Windows, not in Linux) and Impress does have templates, but none is "Empty" like the one which opens when you say new document...

schnedan gravatar imageschnedan ( 2017-11-17 20:02:20 +0200 )edit

'File' > 'New' > 'Templates' > 'Filter'
'File' > 'Templates' > 'Manage Templates' > 'Filter' ('All Applications' e.g.) If no template for 'Draw' is shown there this means that you did not create one. An internal template is used then.

Lupp gravatar imageLupp ( 2017-11-17 22:08:03 +0200 )edit
0

answered 2017-11-17 07:08:57 +0200

updated 2017-11-17 07:17:08 +0200

Analyzing tdf#102204, it is most likely that this problem is specific to paperconf on non-Windows systems. When no user locale is explicitly set, LibreOffice checks paperconf first, before turning to environment settings (which are processed only if no paperconf data, in this order: LC_ALL - LC_PAPER - LANG).

So, if the locale is "Some_Locale (default)" in LibreOffice (i.e., LibreOffice will ask system settings), and paperconf returns letter, then the result will be Letter page in new documents (when no template is used); and that is by design. Setting PAPERSIZE environment variable to a4 should fix the issue.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-07 23:07:48 +0200

Seen: 744 times

Last updated: Nov 17 '17