Ask Your Question

Adding number to formula automaticly

asked 2017-11-09 20:39:30 +0100

ShayG gravatar image

updated 2017-11-09 20:40:35 +0100


As I can see in LibreOffice Math guide (p29, the equations are numbered like this: (#) [some equation] or (1) y=ax+b

How can I create an automatic formatting like this? My LO is v5. (Installed with the package manager, please don't send me to compile the latest version).


edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2017-11-10 12:11:35 +0100

ShayG gravatar image

I read it. But when I press F3 (No fn on keyboard since there is no need for one) nothing happens.

edit flag offensive delete link more


you should type "f", followed by "n", and after that press F3.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-10 12:36:49 +0100 )edit

answered 2017-11-09 21:54:02 +0100

Lupp gravatar image

updated 2017-11-09 22:03:50 +0100

Did you actually read the chapter "Formulas in Writer documents" starting on p29? The cryptic fn+F3 (two letters and the third function key) described there should be what you want. At least this works for me. It creates a table with two columns and one row where a default example of a formula (dummy / placeholder) is inserted into the left column and a number range field into the right column.
If you want to start the numbering anew for a new chapter e.g. you need to edit the 'Number range' field (dblclick) and replace the default 'Value' Text + 1 by the first numner you want to use.

edit flag offensive delete link more


I've managed to remap fn+F3 to another keyboard shortcut. It does nothing.

ShayG gravatar imageShayG ( 2017-11-10 15:34:45 +0100 )edit

I don't understand.
-1- In a 'Writer' text create a new paragraph pressing ENTER.
-2- Hit three keys immediately consecutive: F, N and F3. Case of F and N shouldn't matter.
-3- As by a wonder the one-row-two-column-table I told of will be created.
If this doesn't work for you, tell your OS (exact version) and the version of your LibO to enable visitors of the thread to test.
I personally tested successfully with different versions of LibO including the recent under Win 10.

Lupp gravatar imageLupp ( 2017-11-10 18:39:57 +0100 )edit

All I get is selected fn...

OS: Arch Linux LO:

ShayG gravatar imageShayG ( 2017-11-10 18:57:38 +0100 )edit

The fnF3 is an 'AutoText' > 'Standard' function. "fn" (or"FN") is the identifying code, and the special key F3 triggers the execution. "FN" must be separated from other text at least by spaces,cursor immediatly at the right. It would be strange but... Is your keyboard customized in a way undermining the F3 functionality?
Try > 'Tools' > 'AutoText' > 'Standard' > 'Formula Numbering'. Also look for the assignment to the F3 key in 'Customize', tab 'Keyboard'. It should be 'Run Autotext Entry'.

Lupp gravatar imageLupp ( 2017-11-10 19:45:10 +0100 )edit

Well, that's quite the mysterious trick! I had to read through all of the comments before I understood. But it worked well in my tests, Ubuntu Linux with LO and also Windows 10.

Jim K gravatar imageJim K ( 2017-11-10 23:41:57 +0100 )edit

I think it's important to note that using "fn" assumes that you have the English version of LibreOffice. In the French version, for example, you have to do nf+F3.

joshisanonymous gravatar imagejoshisanonymous ( 2018-06-24 22:14:03 +0100 )edit

To hell with these silly "localizations"! They aren't good for anything but undermine the ability of the community to help. Whoever is capable of keeping in mind a few dozen English terms should use an English UI and English function names in Calc. (I'm a German living in Germany.)
Here "fn" is meaningless anyway. It may remind of "function". Shouldn't it better remind of "typeset formula"? We can handle that, can't we? I won't file an enhancement request to change the letters to "tf".

Lupp gravatar imageLupp ( 2018-06-25 00:28:13 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2017-11-09 20:39:30 +0100

Seen: 1,275 times

Last updated: Nov 10 '17