We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

Which version of Firebird is used in LibreOffice 5.4.1.2 (Windows)? [closed]

asked 2017-11-10 06:49:41 +0200

gunjan gravatar image

updated 2020-10-19 20:20:50 +0200

Alex Kemp gravatar image

There are many security vulnerabilities that exist in Firebird 2.0. Following is the list of them: - CVE-2007-3181 CVE-2007-3527 CVE-2007-4664 CVE-2007-4665 CVE-2007-4666 CVE-2007-4667 CVE-2007-4668 CVE-2007-4669 CVE-2007-5246 CVE-2008-0387 CVE-2008-0467 CVE-2009-2620

If LibreOffice is using 3.0 or above then it should be fine. Can somebody confirm the same?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-10-19 20:28:49.428284

1 Answer

Sort by » oldest newest most voted
0

answered 2017-11-10 07:03:55 +0200

Since commit 860ecb9e583627ab43097784ad98b41afd983ff6, which is of 2017-01-05, and is included into LibreOffice 5.3 (as seen in Release Notes), we have Firebird 3.0.

edit flag offensive delete link more

Comments

FYI: previous version of FB isn't 2.0, but 2.5 (which followed 2.1), and it doesn't contain those vulnerabilities (at least since beta 2). And they got fixed in 2.0 and 2.1 subsequent bugfix releases, too

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-10 07:13:14 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2017-11-10 06:49:41 +0200

Seen: 161 times

Last updated: Nov 10 '17