Ask Your Question
0

How do you get the spell checker to work?

asked 2017-11-11 16:18:55 +0200

OldFool gravatar image

I am a novice to Linux. I installed LibreOffice5 with the expectation that all features function. When I invoke the spell checker it immediately says the the spell check is complete without doing any correction what so ever. Please tell me what I am doing wrong.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2017-11-11 21:38:15 +0200

ajlittoz gravatar image

updated 2017-11-12 21:50:21 +0200

You're not doing wrong. The core package for LO is delivered in a minimal form, kind of one config fits all, i.e. it provides base functionality for all languages.

Out-of-the-box LO package only contains en_US language (by the way, you didn't mention your language or the the languages you intend to use). Other English variants with larger dictionaries are packaged in the English language pack (on my Fedora distro, the package name is libreoffice-langpack-en). Many language packs are available to install.

One way to check what is installed is to go to Tools>Options, then Language Settings>Writing Aids. Click the topmost Edit button. The menu at top will show you which languages are installed: they have an A before their name in the list. Selecting a language will show which type of tool is available: spelling checker, grammar checker (don't count on this one, it is usually an add-on), hyphenator and thesaurus.

If the language you need is not in the list, install its language pack with your distribution tool (you didn't mention it either).

Another subtler cause for immediate return may be that your text does not belong to any language. Text language is an attribute which is set by styles. The styles system is the fundamental concept in LO Writer. You better get quickly familiar with them.

To check, display the style side panel (F11). Right-click on Default Style and choose Modify. Go to the Font tab and check the Language drop-down menu. If it reads [None], your text could be nonsense, it would be just the same with regard to spell-checking.

The best way to define a default language is through Tools>Options, then Language Settings>Languages where you can choose various defaults.

I recommend you customise your LO by setting relevant parameters in Tools>Options. This will ease your learning curve.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

The problem was with the styles and I have adjusted the language settings as you recommended, thank you for your prompt assistance.

OldFool gravatar imageOldFool ( 2017-11-12 16:01:48 +0200 )edit
1

Then accept the answer, upvote it as soon as you have 3 karma points and close the question for others' benefit.

ajlittoz gravatar imageajlittoz ( 2017-11-12 21:52:31 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-11 16:18:55 +0200

Seen: 158 times

Last updated: Nov 12 '17