Ask Your Question
0

remove hyperlink from image in Writer

asked 2017-11-18 07:48:55 +0200

rabbit001 gravatar image

Assume that you have inserted an image into a Writer document, and that you then select the image and insert a hyperlink. That works as expected. Now assume that you want to remove that hyperlink. How do you do that? The "Clear Direct Formatting" option is not offered. If, within Writer, you edit the hyperlink so that all its fields are empty, then within Writer the hyperlink appears to be gone. But if you then "Export as PDF" the document, the hyperlink is still active in the PDF. Because of the deletion of the hyperlink text, the link points to a meaningless location (the directory containing the "odt" file), but it remains an active link. How do you cause the hyperlink to be truly gone?

edit retag flag offensive close merge delete

Comments

Yes, that's a bug (worth filing a report). It keeps working as if there's a link on export, until saved and reloaded.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-18 13:19:02 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-11-19 07:33:59 +0200

rabbit001 gravatar image

Thanks for both suggested workarounds above. Removing and reinserting the image was problematic, since some of my images were screenshots that had not been captured in files. Therefore I tried the suggestion involving "Styles and Formatting/Frame Styles". Switching from "Graphics" to "Frame" and back to "Graphics" did remove the hyperlink, and the image did move on the page as KH mentioned. The movement was due to a change of anchor type that occurred in this process, so all that was required to restore the image location was to select the original anchor type. Next I tried a variation of KH's technique: from the "Styles and Formatting/Frame Styles" list, I simply double-clicked on "Graphics". The hyperlink was removed, and the image did not move. A very successful workaround.

edit flag offensive delete link more

Comments

Glad to hear that it worked for you. It would be great if you accept and upvote the answer accordingly. Also FYI: this should be a comment, not an answer - hover over "more" to see options to move it.

KH gravatar imageKH ( 2017-12-18 14:45:28 +0200 )edit
0

answered 2017-11-18 09:35:09 +0200

PèreOrval gravatar image

A work around is to remove the image and then insert it again.

edit flag offensive delete link more
0

answered 2017-11-18 09:57:14 +0200

KH gravatar image

There is a "Remove Hyperlink" command which works for text hyperlinks, but it doesn't seem to work for images even if you add it to the context menu manually. This looks like a bug to me.

I found a workaround, which is to reapply the frame style for the image, which is "Graphics" by default. Open the styles sidebar (F11) and open the Frame tab (3d from the left).

Unfortunately, this workaround will probably reset the position of the image, assuming it was placed manually.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-18 07:48:55 +0200

Seen: 392 times

Last updated: Nov 19 '17