Ask Your Question
0

How do I format a string as text rather than as a "number"?

asked 2017-11-24 03:26:16 +0200

Timbertoe gravatar image

For example, the string 24-43-24-03-00037.0280 when downloaded to LibreOffice formats as 2.44324030003703E+016 when formatted as General or 24,432,403,000,370,300.00 when formatted as Number. Obviously, neither are what I need! If I could change the number of decimal places would probably solve the problem, but that sounds like making 3 left turns rather than one right turn! This should not be this difficult!!

edit retag flag offensive close merge delete

Comments

Quoting @Timbertoe: "...the string 24-43-24-03-00037.0280 when downloaded to LibreOffice…."
I would need to know in what way you "download".
Are you talking of importiing data via a link? ...import / open a file of any csv-flavor? ...paste something copied elsewhere?
The answer will depend on the case, imo. And, again depending on the case additional info may be needed..

Lupp gravatar imageLupp ( 2017-11-24 11:48:46 +0200 )edit

I can enter that exact string perfectly fine and it results in Text cell content not converted to number. I also can't imagine right now a locale where that even could result in number. So please explain in detail what you are actually doing.

erAck gravatar imageerAck ( 2017-11-24 12:55:53 +0200 )edit

I am sorry I was not clear. I imported a CSV file. IIn Import, the column heading is Standard which the dacs say can and will figure out what to do, but it is not working in this odd case.

Timbertoe gravatar imageTimbertoe ( 2017-11-26 18:41:49 +0200 )edit

Standard means the field can be interpreted as number or date or not, depending on the content. Still I would like to know in which locale context you are importing that takes 24-43-24-03-00037.0280 as number.

erAck gravatar imageerAck ( 2017-11-26 19:58:32 +0200 )edit

A chunk of the csv might help to find advice - and to clear the case generally. Locale and document language?

Lupp gravatar imageLupp ( 2017-11-26 22:04:34 +0200 )edit

My thanks to all! The answer was to change the Type to Text in the CSV import dialog. Sorry I did not see that option earlier nor did I see "Answers" above - I just did not scroll down past the comments. Thank you all for your patience with a CALC newbie! :) Also, when looking at the data with UltraEdit (which I had not done previously), it was obvious that the Import was messing up the format. Thanks again.

Timbertoe gravatar imageTimbertoe ( 2017-11-28 15:19:03 +0200 )edit

Accept answer which helped you and be more clear next time as I wouldn't suggest adding apostrophe if you mentioned importing CSV. I guess made first answered first without that important detail.

Kruno gravatar imageKruno ( 2017-12-09 17:41:45 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-11-26 19:54:28 +0200

erAck gravatar image

In the CSV import dialog select the column in question and set its type to Text.

edit flag offensive delete link more
-1

answered 2017-11-24 09:50:34 +0200

Kruno gravatar image

updated 2017-11-24 09:50:50 +0200

Did you try to add apostrophe as first character

'24-43-24-03-00037.0280

or did you try format cell as text. I don't think that anything else would work as you have digits which are actually not a number, but – as you said it in first few words of the question – numeric string of text.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-24 03:26:16 +0200

Seen: 946 times

Last updated: Nov 28 '17