Ask Your Question
0

Default template in Writer selects wrong page size

asked 2017-11-24 21:45:31 +0200

dmanuel gravatar image

updated 2017-11-25 16:45:43 +0200

floris v gravatar image

I'm using LibreOffice 5.4.2.2.0 on Debian. I've read that the templates are supposed to be formatted according to locale, but mine aren't. I'm set to US English, but all the templates are in A4 instead of Letter. Is there a way to fix this other than modifying the templates myself?

edit retag flag offensive close merge delete

Comments

Do you have your locale in LibreOffice set to Default - English (US) (note the Default part)? And what does paperconf say? See this FAQ.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-24 22:42:43 +0200 )edit

By the way: The USA are the only country in the world sticking to such outdated standards of paper sizes as 'Letter' or 'Legal' are. (There are a few more where such paper is used to some degree regarding the sheer power of their elephant neighbor.) Everywhere else the ISO standards for paper sizes (based on A0 and its aspect ratio allowing for a bisection sequence) are accepted for office use.

Lupp gravatar imageLupp ( 2017-11-26 12:10:26 +0200 )edit

Thanks, but since I live in the US, that really isn't relevant to my question in any way. I can wish and hope for the US to start using and selling A4 paper if it will make you more comfortable, but it doesn't help me with what I need now.

dmanuel gravatar imagedmanuel ( 2017-11-27 20:13:02 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-11-25 18:35:17 +0200

dmanuel gravatar image

Yes. It was on Default - English (US). paperconf gave me "a4." I have now set it to "letter" but the default templates in Writer are still set at A4. Do you think removing and reinstalling LO at this point will fix the issue?

edit flag offensive delete link more

Comments

Well, you know, I seem to need some lessons on reading. Sorry. I didn't notice that "templates" part, and thought of the default page size of new document created without a template.

Actually I must say that I don't know if the reinstalling would change something, but I highly doubt that. It's possible that there are two sets of the templates - for A4 and for Letter, I don't know.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-25 18:48:42 +0200 )edit

Thanks. I tried reinstalling; it didn't fix it. I'm not sure why I would've gotten the wrong templates. Guess this is one of those things I'll just live with.

dmanuel gravatar imagedmanuel ( 2017-11-25 19:25:49 +0200 )edit
0

answered 2017-11-25 19:08:08 +0200

floris v gravatar image

updated 2017-11-25 19:23:44 +0200

I just tried. I'm in the Netherlands, so had to change the locale to English (US) with a file open. No effect. Closed the file, made a new document from scratch, and it's Letter sized. If your current Default template has A4 selected specifically, the page size may not change to Letter if you change the locale. In that case, start a new document, set the page size to Letter, save as template and then set that as the Default template. See [Tutorial] Creating a new default template for more information.

edit flag offensive delete link more

Comments

Thanks. I've done that, but I don't understand why the default template was the wrong size to begin with. I haven't run into that issue with LO on Windows, Mac, or previously in Linux Mint.

I guess it isn't a huge deal, as I'm probably not going to use the other templates much anyway. Just curious if I had something configured wrong by my own doing (I am pretty new to Linux in general and very new to Debian, and trying to learn as much as I can).

Thanks for your help.

dmanuel gravatar imagedmanuel ( 2017-11-25 19:20:27 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-24 21:45:31 +0200

Seen: 71 times

Last updated: Nov 25 '17