Ask Your Question

Characters with irregular spacing [closed]

asked 2017-11-25 03:17:29 +0100

RaphaelSilva gravatar image

updated 2020-10-21 15:01:42 +0100

Alex Kemp gravatar image

Some fonts have this thing that they glue certain characters together (I think it's called ligature). It might look beautiful in some cases, but the problem is when you change characters spacing. Look what happens with the font Lato size 43 pt when spacing is set to 6 pt:

It looks horrible and makes me ill.

Is there anything I can do about it? I'm using LibreOffice Writer 5.4.3 on Ubuntu 16.04.

I was able to get the spacing I wished by inserting a tiny space between the linked characters (image below), but that's actually a really ugly solution.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-07-21 13:26:09.405061


I suppose that it's a good enhancement request - that the ligatures be disabled when spacing isn't single. But it should be filed to bug tracker.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-25 05:01:34 +0100 )edit

1 Answer

Sort by » oldest newest most voted

answered 2017-11-25 09:42:21 +0100

RGB-es gravatar image

Since 5.3 you can manage OpenType features quite easily. To disable ligatures just add :-liga to the font name. In your case it would be


I wrote an article about OpenType features and LibreOffice for site (more to come on my personal blog):

How the OpenType font system works

edit flag offensive delete link more


This is very useful! And so is your article! I had no idea we could use these tags on LibreOffice.

RaphaelSilva gravatar imageRaphaelSilva ( 2017-11-25 14:46:58 +0100 )edit

Question Tools

1 follower


Asked: 2017-11-25 03:17:29 +0100

Seen: 392 times

Last updated: Nov 25 '17