Ask Your Question
2

Characters with irregular spacing

asked 2017-11-25 03:17:29 +0200

RaphaelSilva gravatar image

updated 2017-11-25 16:33:12 +0200

Some fonts have this thing that they glue certain characters together (I think it's called ligature). It might look beautiful in some cases, but the problem is when you change characters spacing. Look what happens with the font Lato size 43 pt when spacing is set to 6 pt:

It looks horrible and makes me ill.

Is there anything I can do about it? I'm using LibreOffice Writer 5.4.3 on Ubuntu 16.04.

I was able to get the spacing I wished by inserting a tiny space between the linked characters (image below), but that's actually a really ugly solution.

edit retag flag offensive close merge delete

Comments

I suppose that it's a good enhancement request - that the ligatures be disabled when spacing isn't single. But it should be filed to bug tracker.

Mike Kaganski gravatar imageMike Kaganski ( 2017-11-25 05:01:34 +0200 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2017-11-25 09:42:21 +0200

RGB-es gravatar image

Since 5.3 you can manage OpenType features quite easily. To disable ligatures just add :-liga to the font name. In your case it would be

Lato:-liga

I wrote an article about OpenType features and LibreOffice for Opensource.com site (more to come on my personal blog):

How the OpenType font system works

edit flag offensive delete link more

Comments

This is very useful! And so is your article! I had no idea we could use these tags on LibreOffice.

RaphaelSilva gravatar imageRaphaelSilva ( 2017-11-25 14:46:58 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-25 03:17:29 +0200

Seen: 159 times

Last updated: Nov 25 '17